7

I'm trying to install Kali Linux alongside with my Windows 8.1 using live USB , but I can't because Kali is unable to see my partitions and unallocated space in my disk which I prepared 50GB unallocated space to install Kali in there.

Kali just let me to install on all disk and doesn't show any partition or unallocated space so I can install there! Help please.

OS: Windows 8.1 (64)
Disk style: MBR
My partitions(5): C,D,E,F,G
Disk size: 250 GB

I even created ext4 partition with Minitool Partiotion Wizard but still Kali wasn't able to see it! When i run fdisk -l command on kali terminal I can see partitions but even GParted can't detect partitions.
I created bootable USB disk for Kali using Universal-USB-Installer app and everything is working fine in Live mode.
Update: These are screenshots I took:

enter image description here enter image description here enter image description here enter image description here

My disk info (XML file)

7
  • Is it have some option to configure your disks manual? Commented Feb 10, 2015 at 16:55
  • @ValeriRangelo:Yes it has. But still it can't detect any partition or unallocated space! Also GParted shows my disk as a 250 gb unallocated space!!!
    – HBasiri
    Commented Feb 10, 2015 at 17:03
  • xmm, did you try with other distro? Commented Feb 10, 2015 at 17:06
  • No!And unfortunately this is my first experience with Linux :D But i installed Kali on VMWare before but there wasn't any problem like this one.
    – HBasiri
    Commented Feb 10, 2015 at 17:08
  • Don't give up. I don't known from what is your problem that's why I told you to test with other disro or Live USB. If you don't have problem then, it means the problem is in Kali. Commented Feb 10, 2015 at 17:57

2 Answers 2

2

Maybe the disk has a hybrid partition table (both MBR and GPT) with both parts not in sync.

You could have a look at the second sector of the disk and (after a backup) overwrite it with zeros:

dd if=/dev/sda skip=512 bs=1 count=16 | command od -t c -t x1

backup with

dd if=/dev/sda of=/media/whatever/sector1.dd skip=1 count=1

overwrite with

dd if=/dev/zero of=/dev/sda seek=1 count=1
6
  • Before i go further can you look at my disk info i created from Disk Editor software.(XML file) mediafire.com/download/ht9k6wvc0j1hn1s/hddinfo_default.xml
    – HBasiri
    Commented Feb 11, 2015 at 6:05
  • It doesn't look like a hybrid PT scheme - there is a logical partition, and hybrid scheme doesn't allow that (iirc).
    – peterph
    Commented Feb 11, 2015 at 10:26
  • @peterph: So what should i do??
    – HBasiri
    Commented Feb 11, 2015 at 10:28
  • @peterph I have read that, too. Doesn't make sense to me, though. However: In this case the GPT would be wrong anyway so that wouldn't be an argument. Commented Feb 12, 2015 at 13:48
  • @HBS try another distribution as ValeriRangelov suggested. It really seems like a bug in Kali.
    – peterph
    Commented Feb 12, 2015 at 21:05
-2

Possibly Windows was shut down incorrectly. Try booting back into Windows and shutting down cleanly with Start, Power, Shutdown

2
  • OP's problem was solved 18 months ago. Commented Aug 27, 2016 at 16:04
  • How could that even screw up the partition table?
    – Oskar Skog
    Commented Feb 26, 2020 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .