1


I'm using Linux Mint Cinnamon 17
When I try to install packages I get "check internet Connection"
I've looked for this error.. I've found that I must edit the "Software sources" In Software Manager..
The funny thing is that the option is disabled.. clicking it restarts the program!!!
Software disabled
I've tried to replace files in /etc/apt/
with the equivalent files in a live cd but it didn't work out.. Help!

3
  • I don't understand why "check internet Connection" means you need to edit your "Software sources". First, assuming that "Software sources" corresponds to /etc/apt/sources.list, can you paste the contents of /etc/apt/sources.list into your question, please? Feb 10, 2015 at 15:23
  • The content is only these 2 lines!! #/etc/apt/sources.list deb cdrom:[Linux Mint 17 Qiana - Release i386 20140624]/ trusty contrib main non-free Feb 10, 2015 at 15:26
  • Ok. Yes, You need to add some network sources then. But paste in the question so people see it please. Just edit the /etc/apt/sources.list file directly. Feb 10, 2015 at 15:31

2 Answers 2

1

It seems like you have changed lsb-release..
replace it with the original file

1
  • That's right!..let me try it first Feb 10, 2015 at 17:28
0

It tells you to check the internet connection because it is having trouble connecting to the repository. Solution: update the software repository using Synaptic Package Manager

Open Synaptic Package Manager From the menu go to Settings > Repositories

Next to Mirrors select one of the servers from the dropdown list of available Mirrors. Do this for the Main and Base mirrors. The top one will be the one with the highest speed, so that is likely to be the best one to use.

After changing the mirrors click "Update the Cache" from within the same view.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .