0

I am logged in on a redhat linux computer, and I don't have root permissions. I have tried running/installing wine on a folder using ./configure , which outputs:

configure: error: X 32-bit development files not found. Wine will be built without X support, which probably isn't what you want. You will need to install 32-bit development packages of Xlib/Xfree86 at the very least. Use the --without-x option if you really want this.

Can I download and install ALL the packages required to install wine manually? ( I tried installing a few rpm packages, and it seemed like it worked.)

And if so, where do I find the full list of rpm's I need for wine?

1
  • 1
    Welcome to U&L, please read the help tour. – Anthon Feb 10 '15 at 11:43
0

I will try to explain you how rpm files work and why you will not be able to install them without a lots of cheating.

rpm files are archives that deploys lib, binaries and conf files in the standard RHEL file hierarchy.
Problem is most path to those folders will not be user writable /lib, /bin or /etc.

If you need to install wine you will need to install all requested dependencies and binary in a subfolder where you wan write and change your root to this folder with the command chroot (almost impossible).

This exercise is complex and it's very unlikely someone without experience would succeed in such an experiment. By the way, if you're not admin, there's probably a reason and if you ask your sysadmin to install wine and he refuses, there's major chances that even if you succeed installing wine, your sysadmin would be very upset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.