16

I have a Debian machine with xrdp-sesman setup following way

Xvnc           127.0.0.1:5910
xrdp-sesman    127.0.0.1:3350
xrdp             0.0.0.0:3389

I am connecting to this machine with rdesktop from another Debian machine.

Everything works great, except clipboard (i.e. using Ctrl+c Ctrl+v to copy and paste). When I connect from my Debian machine to a windows machine using the same rdesktop client, the clipboard works OK.

I suspect that the reason why clipboard does not work when connecting to sesman is that it is using rdp over vnc (or something like that). I don't understand how sesman works, I have just reused config I have found somewhere.

This is my /etc/xrdp/xrdp.ini:

[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=low
channel_code=1

[xrdp1]
name=sesman-Xvnc
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=-1

How can I make clipboard work when connecting to xrdp-sesman with rdesktop client?

  • Have you tried starting rdesktop with -r clipboard:CLIPBOARD? – kirill-a Feb 12 '15 at 13:15
  • 1
    @kirill-a - using -r clipboard:CLIPBOARD makes no difference. Besides, when connecting to windows machine, clipboard works even without this option. – Martin Vegter Feb 12 '15 at 14:58
1

I've found that there are two clipboard buffers (the Ctrl-C/Ctrl-X/Ctrl-V one, and the middle-click one), and the FreeRDP package (used by Krdc) only notices the first one.

What's worse, the terminal emulator I'm using (Terminator, but it's using the Gnome Terminal widget) requires me to use Shift-Ctrl-C to copy something into the relevant buffer.

It may be that xrdp-sesman is similarly constrained by the limits of the RDP protocol. See if the Ctrl-C/Ctrl-X/Ctrl-V clipboard is the one that works.

Apologies for not having a completely definitive answer, but hopefully it will help.

0

Are you running vncconfig? one of the things it does is copy the clipboard.

-2

Try use option -r clipboard: PRIMARYCLIPBOARD

On some systems is need to check both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.