0

I installed RHEL 7 using server with GUI with no added option on my local virtualbox, but I cannot get Firefox connected to the Internet.

  1. I checked /etc/resolv.conf contains nameserver setting
  2. I can ping other servers, such as 8.8.8.8
  3. I open the firewall config GUI, I can see connected is at the left corner, I added http, https and 80, 443, 8080 and 8443 in public zone, and set interface to use public zone

Firefox cannot get connected, and I can't curl either. Could some RHEL experts explain what I am missing?

  • Can you ping www.google.com ? – Konstantinos Feb 9 '15 at 23:20
  • Can you ping your default gateway/router/internal network from virtualbox?Did you use static ip or DHCP? Temporary disable firewall and try to connect to internet. – supriady Jan 3 '17 at 3:22
1

I will answer my own question

I was using VirtualBox 4.3.14 on Windows host, after upgraded to latest 4.3.22 everything start working. Without any RHEL config changes.

1

Despite having checked /etc/resolv.conf you must make sure that DNS is actually working. Try to make a simple request such as dig www.google.com and see whether you get a response.

If that works you can try to manually open a connection with telnet like this:

telnet www.google.com 80

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.