1

Today I installed Archlinux and I tried to install the following package 'dpkg' from the AUR. I tried 2 methods:

pacman -S dpkg

and after that failed I downloaded the *.tar.gz and tried:

pacman -U dpkg.tar.gz

At the first option I got the following error:

[root@localhost andreas]# pacman -S dpkg
Fehler: Ziel nicht gefunden: dpkg

and at the second option I got this error:

[root@localhost Downloads]# pacman -U dpkg.tar.gz 
Lade Pakete...
Fehler: Fehlende Paket-Metadaten in dpkg.tar.gz
Fehler: 'dpkg.tar.gz': Ungültiges oder beschädigtes Paket

The error is in German and means "Invalid or Damaged Package". I don't get why pacman can't find the package because it's here:

https://aur.archlinux.org/packages/dpkg

I'm fairly new to Archlinux, I have mainly used Debian and its Derivates before.

5
  • Have you looked at the AUR description on the wiki ? The AUR doesn't contain any built packages.
    – Leiaz
    Feb 9, 2015 at 14:42
  • Probably a better link if you are a native German speaker. wiki.archlinux.de/title/Arch_User_Repository. (Lesen Sie auf Deutsch!) :) The German version does not appear to have as much info, but may be easier to read. AUR is not officially supported, but is useful. yaourt is pretty good at helping with these packages.
    – No Time
    Feb 9, 2015 at 15:00
  • 1. You need to read the wiki for the AUR. 2. Why would you want to install dpkg? At a guess, this is an XY problem.
    – HalosGhost
    Feb 10, 2015 at 12:53
  • I need dpkg to install Nero Linux, the problem is solved now.
    – Aragok
    Feb 10, 2015 at 22:50
  • the dpkg url return 404. May 11, 2021 at 9:36

2 Answers 2

2

The file dpkg.tar.gz is the instructions to actually build the package. Do this, in the directory in which dpkg.tar.gz resides:

tar xf dpkg.tar.gz
cd dpkg
makepkg

I had to resolve some dependencies with pacman -S some-stuff to get makepkg to finish. I was left with a file dpkg-1.16.15-1-x86_64.pkg.tar.xz. That's the package file. You have to do this to install it:

pacman -U dpkg-1.16.15-1-x86_64.pkg.tar.xz
2
  • 1
    Use makepkg -s to make it install the dependencies as well.
    – muru
    Feb 9, 2015 at 14:59
  • Thx it worked for me.
    – Aragok
    Feb 10, 2015 at 22:51
0

Much simpler way: First check the AUR, to find the package "dpkg". You also would find a comment telling you to change the source URL. So, when I then used "trizen -S dpkg" (it installs from AUR) I was asked to edit the PKGBUILD say "y", so then I changed the source URL in the PKGBUILD file, and continued installation and everything worked flawlessly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .