1

I'm running elementary OS Freya (based on Ubuntu 14.04) on a MacBook Pro 13.3" 2013 Retina and I'm having weird DPI problems:

  1. Some applications (eg Google Chrome) have no awareness of DPI settings and so they just display natively. All other applications display scaled up (text is readable) while Google Chrome text displays at 12px physical pixels, meaning text is extremely small.
  2. I have a 23" 1080p monitor connected to DisplayPort and the DPI settings seem to stay the same across monitors. This means that my 1080p display looks like it's at 640x480, everything is HUGE and on the internal MacBook screen (2560x1600), things look normal.
  3. xrandr doesn't seem to remember my monitor settings, as I'll set my main screen to off and when logging in, it always turns on, screwing up the DPI on my external monitor.

I believe that I'm running Wayland on here, though I can't find any processes with ps aux | grep wayland:

$ aptitude search '~i wayland'
i A libwayland-client0                  - wayland compositor infrastructure - client lib
i A libwayland-cursor0                  - wayland compositor infrastructure - cursor lib
i A libwayland-egl1-mesa                - implementation of the Wayland EGL platform -- 
i A libwayland-server0                  - wayland compositor infrastructure - server lib

I don't have any System Settings which control the DPI in the GUI.

I've tried using xrandr --dpi 75 and nothing changes. Restarting applications also doesn't seem to have an effect.

See what I mean?

I think that it's running Wayland inside of X server. Is there any configuration file I could use to change the DPI globally or per-monitor?

0

It appears that this scaling is actually controlled by GNOME Settings and is independent of Wayland:

gsettings set org.gnome.desktop.interface scaling-factor 1

This fixes things for me.

I'm hoping that Wayland will still bring an awesome solution at the display-server-level for dealing with different DPIs on different monitors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.