13

My screen is just too bright. How can I adjust screen brightness? So far I tried the following:

  1. "Brightness and lock" settings doesn't work.
  2. Fn + F6 or F7 doesn't work.
  3. This doesn't work.
  4. This doesn't work too.

My Laptop is Toshiba Satelite L745

6 Answers 6

14

You can try xrandr tool.

First run xrandr --verbose and look for a line with resolution like LVDS1 connected 1024x600+0+0. The name of your display (LVDS1 in this example) is needed here. Now you are ready to set brightness:

xrandr --output LVDS1 --brightness 0.4

xrandr sets software, not hardware brightness so you can exceed both upper and lower limits:

xrandr --output LVDS1 --brightness 1.7
xrandr --output LVDS1 --brightness -0.4  #negative value is also possible
xrandr --output LVDS1 --brightness 1
3
  • 2
    It still too bright. The way xrandr do is just filtering the colors Is there anyway to access hardware brightness?
    – Mas Bagol
    Feb 7, 2015 at 7:00
  • For all that accessing the hardware brightness would be better, this was useful to me. Thanks.
    – mc0e
    Feb 19, 2020 at 12:56
  • I like how this method can even control the perceived brightness of external monitors (which can be much faster than adjusting a external monitor's brightness using its stupid digital button interface). I miss the days of analog knobs for controlling monitor brightness and contrast! Jan 1, 2022 at 19:19
5

Before doing this, I installed firmware-linux-nonfree; I don't know whether that's affected anything.


If xbrightness does not detect the backlight, you'll need to find the backlight file and manually set the backlight value yourself. Here's the process I used for my Toshiba Satellite C50-B-14Z:

wizzwizz4@mylaptop:~$ ls /sys/class/
ata_device   devfreq   i2c-adapter    net           scsi_device   vc
ata_link     dma       ieee80211      pci_bus       scsi_disk     video4linux
ata_port     dmi       input          phy           scsi_generic  vtconsole
backlight    drm       iommu          powercap      scsi_host     watchdog
bdi          firmware  leds           power_supply  sound         wmi
block        gpio      mem            ppdev         spi_master
bluetooth    graphics  memstick_host  printer       thermal
bsg          hidraw    misc           rfkill        tpm
devcoredump  hwmon     mmc_host       rtc           tty
wizzwizz4@mylaptop:~$ ls /sys/class/backlight/
intel_backlight
wizzwizz4@mylaptop:~$ ls /sys/class/backlight/intel_backlight/
actual_brightness  brightness  max_brightness  subsystem  uevent
bl_power           device      power           type

Now I've got the brightness file: /sys/class/backlight/intel_backlight/. I can read the value of this file:

wizzwizz4@mylaptop:~$ cat /sys/class/backlight/intel_backlight/brightness
3906

3906?! That's way more than the usual maximum of 15! Checking the max_brightness file:

wizzwizz4@mylaptop:~$ cat /sys/class/backlight/intel_backlight/max_brightness
7812

That... makes more sense. So it's about half-brightness at the moment. Well, I like it quite dim, so I'll set it to 390 out of 7812:

wizzwizz4@mylaptop:~$ echo 390 | sudo tee /sys/class/backlight/intel_backlight/brightness
390

And the screen dimmed! Yay!

5
  • This is the way I'm having to do it. Right now I'm trying to figure out how to achieve this without sudo, and map it to some hot keys. Jan 1, 2022 at 19:23
  • 1
    @LonnieBest My current strategy is to keep a terminal open with sudo tee /sys/class/backlight/intel_backlight/brightness, and Ctrl+Z to "minimise" it. Then I just fg 1 (or fg 2) to switch to it, type in the new brightness… It's not a good solution, but it's tolerable.
    – wizzwizz4
    Jan 1, 2022 at 19:26
  • Have you noticed that you have to reset this every time you walk away from you machine for a few minutes? When I install a desktop environment onto my laptop, I'm able to adjust brightness with the designated keys. Yet, I'm only running a window manager, which doesn't come with such amenities. So, I just need to figure out how the desktop environments achieve this mapping. There's probably package I can install, but I don't know which one yet. Jan 1, 2022 at 19:47
  • 1
    @LonnieBest Desktop environments are doing strange magic behind the scenes. Unfortunately, I use LXDE, which doesn't. ☺
    – wizzwizz4
    Jan 1, 2022 at 19:51
  • 1
    @LonnieBest I have discovered the source of the magic.
    – wizzwizz4
    Feb 26, 2022 at 18:04
3

I found the screen brightness solution in a somewhat obscure article. My issue was my laptop couldn't remember brightness settings upon reboot. I'll post the link at the end of my answer.

All that was needed was to edit the file /etc/rc.local and add one line.

First, back up the rc.local file.  If something goes wrong you can revert to the original file.

cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# screen brightness line added
# it's to make the laptop remember settings at power up.

echo 7 > /sys/class/backlight/acpi_video0/brightness

exit 0

Note that I added the line echo 7 > /sys/class/backlight/acpi_video0/brightness to my rc.local file.

In my Debian Wheezy setup, the value echo 7 > … sets brightness midway between dark and bright. So 7 is perfect for me. Choose a value that suits you.

rc.local runs when you restart your machine.

Here's the link: Installing Ubuntu on Samsung 5 (SSD+HDD) | LinuxMeerkat

Scroll down the page to find how to change default screen brightness on a laptop.

3

After 3⅓ years of putting up with my last solution, I've finally got a better one. This is for LXDE, and other DEs based on Openbox.

  1. Install brightnessctl (which should also come with a brightness-udev package):

    wizzwizz4@mylaptop:~$ sudo apt install brightnessctl
    
  2. Check whether you're in the video group:

    wizzwizz4@mylaptop:~$ groups
    wizzwizz4 cdrom floppy sudo audio dip video plugdev netdev bluetooth lpadmin scanner
    
  3. If you're not in the video group, add yourself to it and then log in again.

    wizzwizz4@mylaptop:~$ sudo usermod -aG video wizzwizz4
    wizzwizz4@mylaptop:~$ lxsession-logout
    
  4. Run xev to work out what your brightness keys are called:

    KeyRelease event, serial 50, synthetic NO, window 0x2a00001,
        root 0x78a, subw 0x2a00002, time 3706596, (39,62), root:(127,354),
        state 0x0, keycode 233 (keysym 0x1008ff02, XF86MonBrightnessUp), same_screen YES,
        XLookupString gives 0 bytes:
        XFilterEvent returns: False
    
    KeyPress event, serial 51, synthetic NO, window 0x2a00001,
        root 0x78a, subw 0x2a00002, time 3709488, (39,62), root:(127,354),
        state 0x0, keycode 232 (keysym 0x1008ff03, XF86MonBrightnessDown), same_screen YES,
        XLookupString gives 0 bytes:
        XmbLookupString gives 0 bytes:
        XFilterEvent returns: False
    

    On my machine, and probably everybody else's too, they're called XF86MonBrightnessUp and XF86MonBrightnessDown, so you can probably skip to step 3.

  5. Edit ~/.config/openbox/lxde-rc.xml. Inside the <keyboard> section (probably at the end of it, just before </keyboard>), add the following:

      <!-- Change the brightness -->
      <keybind key="XF86MonBrightnessUp">
          <action name="Execute"><command>brightnessctl set 6.25%+</command></action>
      </keybind>
      <keybind key="XF86MonBrightnessDown">
          <action name="Execute"><command>brightnessctl set 6.25%-</command></action>
      </keybind>
    

    Adjust to taste. I like the -e flag that comes with Debian 11 (Bullseye).

  6. Make sure you actually pressed save. (I always forget this step.)

  7. Run openbox --reconfigure to reload Openbox's configuration. (Or restart your computer – but I think this is easier.)

Tada!

Note that brightnessctl doesn't come with Wheezy; it was first introduced in Debian 10 (Buster). If you're using an older Debian, you can write a short script to increment / decrement the value stored in the relevant /sys/class/ file, and setuid root it.

1
1

For me on Acer 7530G with:

Distributor ID: Debian Description: Debian GNU/Linux 8.6 (jessie) Release: 8.6 Codename: jessie

The solution was in Application Menu> Settings> xfce4-desktop there can you set the brightness of the monitor, for me was 100 fine.

-1

On my laptop Fn+Up and down is worked, you should try this.

2
  • 1
    Welcome to the site, and thank you for your contribution. Would you mind adding information on what OS flavor and version your laptop is running?
    – AdminBee
    Nov 20, 2020 at 15:27
  • The Fn keys on your keyboard are features of your laptop maker, its model, its built-in keyboard, and its special drivers. Please delete this answer. Thank You. I have returned only to delete my answers too. I appreciate your attempt to answer. We all learn together.
    – Paul
    Oct 17, 2023 at 0:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .