0

I need to setup a radius server with active directory authentication, on a RHEL 6.5 server. I have been following this guide.

As per the guide, I have made necessary configurations which are as follows:

/etc/samba/smb.conf:

[global]
        workgroup = WORKGROUP-NAME-HERE
        security = ads
        password server = PASSWORD-SERVER-HERE
        realm = REALM-HERE
        printing = cups
        printcap name = cups
        ...
        ...

/etc/krb5.conf:

[logging]
 default = FILE:/var/log/krb5libs.log
 kdc = FILE:/var/log/krb5kdc.log
 admin_server = FILE:/var/log/kadmind.log

[libdefaults]
 default_realm = REALM-HERE
 dns_lookup_realm = false
 dns_lookup_kdc = false
 ticket_lifetime = 24h
 renew_lifetime = 7d
 forwardable = true

[realms]
 REALM-HERE = {
 kdc = PASSWORD-SERVER-HERE
 }

Then, joined the domain successfully.

/etc/raddb/modules/ntlm_auth:

exec ntlm_auth {
        wait = yes
        program = "/usr/bin/ntlm_auth --request-nt-key --domain=DOMAIN-HERE --username=%{mschap:User-Name} --password=%{User-Password}"
}

/etc/raddb/sites-enabled/default & /etc/raddb/sites-enabled/inner-module:

...
...
authenticate {
        ntlm_auth
...
...

After all these configurations, I made sure that samba and winbind are running.

But, as soon as I executed radiusd -X, it displayed an error below:

rlm_eap: SSL error error:02001002:system library:fopen:No such file or directory
rlm_eap_tls: Error reading certificate file /etc/raddb/certs/server.pem
rlm_eap: Failed to initialize type tls
/etc/raddb/eap.conf[17]: Instantiation failed for module "eap"
/etc/raddb/sites-enabled/default[313]: Failed to load module "eap".
/etc/raddb/sites-enabled/default[252]: Errors parsing authenticate section.

Where am I going wrong?

0

Commenting out the line make_cert_command = "${certdir}/bootstrap" in /etc/raddb/eap.conf file corrected the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.