When I print something (Firefox 5 but also other apps), the option "color" is always set to "Color (CMYK)". How do I make "monochrome" or "black & white" the default?

This is a Kyocera FS-C5100DN with CUPS 1.4.6-5ubuntu1.3.

[EDIT] Output of lpstat -d -v:

system default destination: FS-C5100DN
device for FS-C5100DN: socket://

So the question is now: Can I change the default somehow on my own computer without changing settings on the server?


You can configure CUPS defaults for your account by running the lpoptions command. Run lpoptions -l to see what options are available for your printer, and determine which one corresponds to the color/monochrome choice. For example, with this output

$ lpoptions -l | grep Color
ColorModel/Color Model: Gray Black *RGB CMY CMYK KCMY

I would set ColorModel to Black. Then run lpoptions -o NAME=VALUE to set a default option. This creates a file called ~/.cups/lpoptions that applications using CUPS will read.

lpoptions -o ColorModel=Black

Other printers may use different parameters, e.g.

lpoptions -o ColorType=Mono

You can define aliases for sets of options and make one of them the default.

lpoptions -p FS-C5100DN/bw -o ColorModel=Black
lpoptions -p FS-C5100DN/color -o ColorModel=RGB
lpoptions -d FS-C5100DN/bw
  • 2
    Note: Color is not a standard option. On my Epson XP-202 it was Ink=MONO, to you really have to | less it up and read in general :-( – Ciro Santilli 冠状病毒审查六四事件法轮功 Apr 22 '15 at 16:42
  • sometimes lpoptions is not working in osx, I had to use lpadmin -p <printername> -o ColorMode=mono for a Canon Printer with OSX 10.11.6 – rwenz3l Mar 1 '17 at 11:13

Most CUPS printer drivers have this in their options settings. I don't know about Ubunutu but a default CUPS installation will include a special local-host only web server that can be used for configuration and management of printers. Try this URL:

From there go to the Printers tab, select the printer you want to modify, then choose "Set Defaults Options" from the Administration menu. My printer has B&W default options under the Printout Mode tab, but yours may vary.

  • The "Printers" tab is empty :-/ Which is odd because I can print (just did it :-) ) lpq can see my printer. My guess is that this is a remote queue. Any idea where I should look for it? – Aaron Digulla Aug 8 '11 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.