0

I got a server from my university computer center, which is a managed server. I'm root on that server.

Now I'm trying to add the dotdeb sources for php 5.6. I did this on my own server and it was piece of cake, by simply following the instructions and adding the sources list to

/etc/apt/sources.list

The problem I get now is that I can't do this on the new server the exact same way, because sources.list is managed by the server. Instead I have to add a file in

/etc/apt/sources.list.d/

So I created the file

/etc/apt/sources.list.d/alamp.list

with the following entries

deb http://packages.dotdeb.org wheezy all
deb-src http://packages.dotdeb.org wheezy all
deb http://packages.dotdeb.org wheezy-php56-zts all
deb-src http://packages.dotdeb.org wheezy-php56-zts all

The command apt-get update seems to see those sources, but it doesn't install php 5.6. It (apt-get update) gives the following lines for php 5.6

Ign http://packages.dotdeb.org wheezy/all Translation-en
Ign http://packages.dotdeb.org wheezy-php56-zts/all Translation-en

But also somewhere before that it gives:

Hit http://packages.dotdeb.org wheezy-php56-zts/all Sources
Hit http://packages.dotdeb.org wheezy-php56-zts/all amd64 Packages

How can I troubleshoot this issue? I want to install php 5.6.

Please ask for any additional information if you need it.

Requests from comments:

apt-cache policy php5

php5:
  Installed: 5.4.36-1~dotdeb.1
  Candidate: 5.4.36-1~dotdeb.1
  Version table:
     5.6.5-1~dotdeb.1 0
        500 http://packages.dotdeb.org/ wheezy-php56-zts/all amd64 Packages
 *** 5.4.36-1~dotdeb.1 0
        700 http://packages.dotdeb.org/ wheezy/all amd64 Packages
        100 /var/lib/dpkg/status
     5.4.36-0+deb7u3 0
        700 http://security.debian.org/ wheezy/updates/main amd64 Packages
     5.4.36-0+deb7u1 0
        700 http://ftp.uni-mainz.de/debian/ wheezy/main amd64 Packages
        700 http://ftp.de.debian.org/debian/ wheezy/main amd64 Packages
3
  • @Braiam Just apt-get update and upgrade. I keep getting php 5.4 and it's not upgrading. This worked though on my personal server. – The Quantum Physicist Feb 4 '15 at 22:22
  • 1
    apt-cache policy pkgname please. – Faheem Mitha Feb 4 '15 at 22:28
  • @FaheemMitha I added the output to the question. – The Quantum Physicist Feb 4 '15 at 22:43
0

Thanks to Faheem, with his comment he put me on the right path to google the right things.

It turns out that the problem was that the university had a file

/etc/apt/preferences

which included definition of priorities of stuff to be installed. Once I removed this, an upgrade with apt-get dist-upgrade happened alone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.