6

I want to use Avahi tools for mDNS service discovery in CentOS 6.6. I have installed the following packages: avahi, avahi-tools, nss-mdns. I checked the Avahi daemon and it is running:

$ service avahi-daemon status
avahi-daemon (pid  1365) is running...

But when I tried running the following avahi-browse command, it halted there and returned nothing:

$ avahi-browse --all

When I tried to launch the Avahi GUI window like the following:

$ avahi-discover
bash: avahi-discover: command not found

Then I searched what Avahi-related packages are on my system:

$ rpm -qa | grep avahi
avahi-autoipd-0.6.25-15.el6.x86_64
avahi-tools-0.6.25-15.el6.x86_64
avahi-glib-0.6.25-15.el6.x86_64
avahi-0.6.25-15.el6.x86_64
avahi-libs-0.6.25-15.el6.x86_64
avahi-ui-0.6.25-15.el6.x86_64

I tried on another computer which runs on Ubuntu Linux and both avahi-browse and avahi-discover work fine. So why don't avahi-browse and avahi-discover work on my CentOS 6.6?

3

avahi-browse, avahi-discover is part of avahi-tools rpm in centos 6.x

sudo yum install avahi-tools avahi-ui-tools

to find out:

sudo yum provides avahi-browser
  • The original question said "I have installed the following packages: avahi, avahi-tools ..." and you can see it in their output from rpm -qa | grep avahi. – Jeff Schaller Jul 9 '15 at 12:13
  • Actually this post contains the correct answer to the avahi-discover problem (one of two separate problems in the question). It is a part of avahi-ui-tools which was not listed by OP. Suggested "how to find out"-way is correct, only the provided example is misleading. – techraf Sep 24 '16 at 12:23
2

Make sure not just avahi-daemon works and is installed, but also avahi-utils. That was my problem.

On debian its

sudo apt-get install avahi-utils

I've never used CentOS, so I don't know how the package manager works, but it should be something similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.