1

I want to disable the right click on a file. It's possible?

I'm actually using Openbox, LXDE and PcManFM.

I had disable the right click to open the menu on the desktop but I want to disable the right click on a file too.

0

2 Answers 2

1
  • In the PCManFM preferences toggle the Show Window Manager Menu option (you might have to click advanced).
  • Remove the line from /etc/xdg/lxsession/LXDE/autostart that is starting pcmanfm.
  • Change openbox-lxde in /etc/xdg/lxsession/LXDE/config to openbox.

See link and link for more options.

13
  • I don't have a file named openbox-lxde.
    – Aragmond
    Commented Feb 3, 2015 at 13:35
  • It should be an entry in file /etc/xdg/lxsession/LXDE/config
    – kirill-a
    Commented Feb 3, 2015 at 13:49
  • In my file /etc/xdg/lxsession/LXDE I don't have a file named config. I need to create him?
    – Aragmond
    Commented Feb 3, 2015 at 14:00
  • No, I guess your config is stored in different place. Don't previous steps help? This last step changes to default openbox menu so you can edit it's config manually, may be you don't need this at all.
    – kirill-a
    Commented Feb 3, 2015 at 14:05
  • 2
    You can completely disable options to copy/paste files to desktop by removing lines desktop_manager/command=filemanager and file_manager/command=pcmanfm from /etc/xdg/lxsession/Lubuntu/desktop.conf
    – kirill-a
    Commented Feb 3, 2015 at 15:24
-1

Remove

<mousebind button="Right" action="Press">
<action name="ShowMenu"><menu>root-menu</menu></action>
</mousebind>

from /etc/xdg/openbox/rc.xml, then reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .