4

I am running software on RedHat Enterprise Linux 7 which requires libwebkitgtk-1.0. Unfortunately RHEL7 comes only with webkitgtk3. In contrast, RHEL6 had only webkitgtk. Other distributions like Debian, Ubuntu and openSuSE provide both versions of webkitgtk. Is there a way I could install the first version on RHEL7?

4

You can download webkitgtk-2.2.4-1.el7.x86_64.rpm for rhel7 for example from http://rpm.pbone.net/index.php3/stat/4/idpl/27127038/dir/redhat_el_7/com/webkitgtk-2.2.4-1.el7.x86_64.rpm.html and then install by rpm -ihv webkitgtk-2.2.4-1.el7.x86_64.rpm

It need libsecret,libwebp, gstreamer1-plugins-base packages - yuu can install it from rhel7/centos7

Alternativly, but "right way" - yuu can add whole epel repository:

yum install epel-release

And then install webkitgtk package by

yum install webkitgtk
3
  • yum install epel-release did not work but manually downloading and installing it worked. webkitgtk installed and my software works now. Thanks! – RegedUser00x Feb 3 '15 at 13:34
  • This was a perfect fix on my CentOS 7 box. – JeremyCanfield Jun 20 '17 at 17:25
  • That command to install epel-release is there by default on CentOS only. It's not available on RHEL systems. For details, see the fedora wiki. – ILMostro_7 Sep 7 '19 at 8:30
1

this is a good link as it led me to a workaround but is the advice still current? I can only see webkit3 and 4 in the latest CentOS 7 repo and not webkit1 or 2(and have installed epel as well)

Name        : webkitgtk3
Arch        : x86_64
Version     : 2.4.11
Release     : 2.el7
Size        : 11 M
Repo        : base/7/x86_64
Summary     : GTK+ Web content engine library


Name        : webkitgtk4
Arch        : x86_64
Version     : 2.16.6
Release     : 6.el7
Size        : 25 M
Repo        : base/7/x86_64

I manually downloaded and rpm installed webkitgtk-2.4.9-3.el7.nux.x86_64.rpm (from https://centos.pkgs.org/7/nux-dextop-x86_64/webkitgtk-2.4.9-3.el7.nux.x86_64.rpm.html ) then used

export SWT_GTK3=0
export SWT_WEBKIT2=0

before launching the application and this worked, but it would be ideal if this could be achieved via yum?

# uname -a
Linux myhost 3.10.0-862.14.4.el7.x86_64 #1 SMP Wed Sep 26 15:12:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

cheers

Rod

2
  • is this a question or answer? – Pierre.Vriens Oct 9 '18 at 17:49
  • Its a bit of both. I am grateful to the original author for posting this and I am sure the first reply was correct at the time of writing. However since replying I have discovered that RedHat removed webkitgtk from the official repository. The link in the original article is broken so I provided the location where people can now download it as well as additional help in the form of SWT_GTK3 in case anyone wants to try this. My question is - is manually installing the rpm the only method or is there another repo I am not aware of which will allow you to yum install it? – RodAllen Oct 11 '18 at 21:59
1

I've traced this issue for almost two days and finally it works!

Here is the solution to install via yum when yum install epel-release doen't work for you.

add nux-dextop repo:

rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-5.el7.nux.noarch.rpm

then install webkitgtk

yum install webkitgtk

you might hit 'y' twice to confirm you want to install webkitgtk from a third-party source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.