0

A little while ago I upgraded my laptop from Linux Mint 16 to 17. Everything went fine, but now I can no longer connect to a specific wireless network that I have at work. When I try to connect, it gives me a "loading" icon, but nothing happens after that. I seem to remember that in Mint 16 I provided a couple of non-default security settings before attempting to connect, but in Mint 17 I can't find any options or settings button before making the connection (I only see this button after I connected to a certain network). Does anyone know a way around this problem?

Connecting to other networks (with standard settings) works well, so I doubt this issue is related to my network adapter drivers or anything.

EDIT: connecting to the specific network did work on Mint 16, but it never worked on 17, having the symptoms described above.

  • It is unclear from your question whether Mint 17 ever worked with the network at your work or not. Please update the question with that information. – Anthon Feb 2 '15 at 10:09
0

Solved it, here's how:

  1. I connected to the public "visitor" network and renamed its connection file in /etc/NetworkManager/system-connections to the name of the network I actually wanted to connect with.
  2. After doing so, I can edit the connection security settings for the target network.
  3. Saved the settings and there we go! The contents of the file in /etc/NetworkManager/system-connections was automatically updated accordingly after a connection was established.
0

You can solve this by clicking the "Connect to hidden network" button and giving it the name of the network you want to connect to.

Tested on Linux mint 17 "Rebecca"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.