1

I have compiled openssl from source on my Solaris machine to a newer location apart from the default one. When I set the newly compiled ssl path in PATH variable and LD_Library path and then compile APACHE 64 bit with CFLAGS and CPPFLAGS and CXXFLAGS all set to -O2 -mcpu=v9 -m64 with apr, apr-util and pcre and ssl, the compiler of apache httpd 2.4.10 goes to the correct directory where i have installed ssl 1.0.1k and but shows me that checking ssl version openssl 0.9.8a >= FAILED. openssl version too old.

When i check the openssl version,its giving me 1.0.1k

I even tried the steps as: ./config --prefix=/export/home /Apache24/openssl-1.0.1k thread shared solaris64-gcc -m32.....this command gives that its already configured on sparcv8.

How can i resolve this, I have to compile apache 2.4.10 with 64bit with SSL.

The below is the message i get when i run httpd compilation:

checking for OpenSSL...
  checking for user-provided OpenSSL base directory... /export/home/Apache24/ssl
  adding "-I/export/home/Apache24/ssl/include" to CPPFLAGS
  setting MOD_CFLAGS to "-I/export/home/Apache24/ssl/include  "
  setting ab_CFLAGS to "-I/export/home/Apache24/ssl/include  "
  adding "-L/export/home/Apache24/ssl/lib" to LDFLAGS
  setting MOD_LDFLAGS to "-L/export/home/Apache24/ssl/lib  "
checking for OpenSSL version >= 0.9.8a... FAILED
configure: WARNING: OpenSSL version is too old
no
checking whether to enable mod_ssl... configure: error: mod_ssl has been
requested but can not be built due to prerequisite failures
1

Check where is installed this new ssl package and use --with-ssl=DIR when exec configure script

  • I have given the correct path as stated above for the new ssl directory where i have compiled in --with-ssl=new openssl directory path.still it states openssl version too old – user3592502 Feb 2 '15 at 7:52
  • Have you run again configure script? Where is installed new ssl? what exactly have you write after -with-ssl? – Romeo Ninov Feb 2 '15 at 8:16
  • i have compiled openssl 1.0.1k in the path /export/home/Apache24/ssl and when i compile httpd i give --with-ssl=/export/home/Apache24/ssl -enable-ssl -enable-so – user3592502 Feb 2 '15 at 9:09
  • You should install openssl. This compilations is not usable. Moreover when install apache you mod_ssl should use openssl libraries – Romeo Ninov Feb 2 '15 at 9:35
  • i have compiled openssl then make and then make install...this installs openssl in the directory specified and mod_ssl is for APache 1.3 , i am using apache 2.4 which has it by default – user3592502 Feb 2 '15 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.