0

I am using CentOS 6.6. I put this content into /etc/init.d/suricata. I also ran

sudo chkconfig suricata on

to make suricata run at boot. My problem is that it is now preventing Centos from booting up. The log ends with three lines all saying

sd 2:0:0:0 [sdb] Assuming drive cache: write through

I tried the Centos rescue disk and managed to get into the command line but /etc.init.d was unpopulated. It appears that it becomes populated later on and the suricata script prevents CentOS from booting up.

Is there a way for me to get rid of /etc/init.d/suricata so CentOS can boot up? In Debian, one can use ctrl-alt-F4 to get to the command line but that is not working in CentOS. It may depend on the reason for the hang.

1

Can you not

Turn machine on edit the kernel line in the grub menu and type "single" so when it boots into single user mode.

http://www.uptimemadeeasy.com/linux/boot-centos-into-single-user-mode/

When the machine comes up you should get a command line where you can type

chkconfig suricata off

Then suricata should not run at start up.

Sorry if I have misunderstood your question.

  • When I type "chkconfig suricata off", I get ""error reading information on service suricata: No such file or directory". Thanks, – OtagoHarbour Feb 2 '15 at 0:37
0

I used the rescue disk to go into the bash shell. I then found the suricata executable in /usr/bin/suricata and renamed it /usr/bin/suricata1 so /usr/bin/suricata could not be found at boot. That enabled me to boot up normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.