0

I am doing a project on Kali Linux's airodump-ng command. Though, whenever I try to execute this command on a virtual machine (Virtual Box) with a Wireless USB adapter, I get this message as appose to a list of BSSID's:

ioctl(SIOCSIWMODE) failed: Device or resource busy
ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.
Make sure RFMON is enabled: run 'airmon-ng start wlan0 <#>'
Sysfs injection support was not found either.

Is there a way to fix this? If so, please respond as soon as possible.

-1

if your system is kali2.0

you should use the commands:

sudo ifconfig wlan0 down

sudo iwconfig wlan0 mode monitor

sudo ifconfig wlan0 up

sudo iwconfig wlan0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.