5

I'm experiencing many problems trying to properly connect and access the memory of my phone from my Linux system.

I'm running openSUSE 13.1, with KDE, and my phone is a Samsung Galaxy S3 Neo equipped with Android 4.4.2 (it is not rooted, it it makes any difference); it can't be connected with a simple USB protocol but it needs to use MTP.

Now I have found that MTP under Linux is not exactly what you will call "working out of the box". Usually I can see the content of the connected device, but I get any sort of error when I try to work with it, i.e. by copying files to and from its memories, both internal and SD card (which, in the end, is the point of having it connected to the computer), without being able to perform these tasks.

By searching on the currently installed packages for "MTP" I can see that only kio_mtp and libmtp9 are installed; do I need something else?

I've also tried to use KDE Connect, a superb application that amongst other things should let me access the phone memory; but when I try to do that, Dolphin (I mean KDE file manager of course) hangs and I must terminate it; I don't know exactly what kind of protocol KDE Connect uses, but it doesn't work for me either.

What should I do to make it work?

  • I've found S3+MTP+Linux to be flaky too. I have had luck with github.com/hanwen/go-mtpfs, but only if I'm "polite" with it (run a single copy command, don't run unison, and sometimes it takes a couple tries to connect at all). I'm not sure if the problem is Samsung or the MTP protocol or what. – P.T. Jan 31 '15 at 0:16
  • MTP never worked reliable for any device I tried. I recommend to use either a) adb or b) ssh for accessing and transferring files. For adb you only need to activate the developer mode in the options. Installing a sshd also does not require rooting (e.g. when using the app SSHelper). With adb-over-usb or ssh-over-wifi I easily get transfer rates like 5 MiB/s. Most GUI file managers support accessing remote fs trees over ssh ('sshfs'). – maxschlepzig Jan 31 '15 at 7:45
  • Try SSHDroid app for android and setup network in dolphin. MTP never has worked relaible for me as well. – Registered User Sep 27 '15 at 12:49
  • I have had success with simple-mtpfs and some LG phones. Might work for you. Indeed, I cannot get these phones to be read-write in Dolphin. – Pistos Feb 11 '18 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.