0

I'm new in the Linux world, but I wanted to install Seafile 4.0.1 on my Cubietruck (Cubieboard 3) with Apache2 and MySQL using these two tutorials:

I ran into a problem as I wanted to install libapache2-mod-fastcgi, but the package was not found. I added the non-free repos in the sources.list file. Didn't help.

Instead I installed libapache2-mod-fcgi and continued with the tutorial. At the point when I had to restart the apache2 server, the error Invalid command 'FastCgiExternalServer occured.

Any help to solve this problem, did I anything wrong?

Some more information:

It's running on Debian 7.8 and uname -a gives output below:

Linux cubietruck 3.4.79 #3 SMP PREEMPT Wed Nov 12 11:39:10 CST 2014 armv7l GNU/Linux

3
  • It sounds like there may be something wrong with your Apache configs. Can you post the output of apachectl -t?
    – jayhendren
    Commented Jan 30, 2015 at 18:36
  • Syntax error on line 270 of /etc/apache2/apache2.conf: Invalid command 'FastCgiExternalServer', perhaps misspelled or defined by a module not included in the server configuration Action '-t' failed. The Apache error log may have more information. I put this line at the very end. Does it matter?
    – bvwidt
    Commented Jan 30, 2015 at 23:33
  • Yep, looks like a screwed up apache config. Look at the mod_fcgi docs and tweak your apache configs until apachectl -t reports Syntax OK. If you post your Apache configuration, I'm sure somebody can take a look at it and help figure out what's wrong.
    – jayhendren
    Commented Jan 30, 2015 at 23:59

1 Answer 1

2

I ran into the exact same problem trying to setup seafile with HTTPS on my new Cubietruck (Cubieboard 3).

The problem is that there's no pre-compiled binary for arch 'armhf' in the repos. So it must be compiled.

And I solved it like this:

apt-get install apache2-threaded-dev cdbs debhelper dpatch libapr1-dev libtool pkg-config
apt-get -b source libapache-mod-fastcgi
dpkg -i libapache2-mod-fastcgi*.deb
# Enable the module if not already done
a2enmod fastcgi

You'll get tons of warnings but finally it worked. Now I'm able to use seafile with HTTPS using apache as reverse proxy for seahub.

My Setup

I'm using the Image from Igor Pecovnik with Kernel 3.4.105 from: http://www.igorpecovnik.com/2013/12/24/cubietruck-debian-wheezy-sd-card-image/

root@x:~# unname -a
Linux x 3.4.105-cubieboard #8 SMP PREEMPT Fri Jan 23 06:11:42 EST 2015 armv7l GNU/Linux

The error (for searching puposes)

The error you get if you try to apt-get install libapache2-mod-fastcgi:

root@x:~# apt-get install libapache2-mod-fastcgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-fastcgi' has no installation candidate

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .