0

I am trying to set up my own mail server (for 'fun'). I followed this tutorial to the bone. But I get this error message:

imap-login: Disconnected (auth failed, 2 attempts in 9 secs): user=<dayuloli@mydomain.com>, method=PLAIN, rip=203.210.7.43, lip=1.2.3.4, TLS: Disconnected, session=<VDW4ua8NzADL0gcr>

I am using the SSL certificate and key I have for my nginx web server, on the same machine.

I disabled plaintext authentication by adding these two lines (as per tutorial) to /etc/dovecot/conf.d/10-auth.conf:

disable_plaintext_auth = yes
auth_mechanisms = plain login

But the method in the log entry still says PLAIN, and TLS is Disconnected. Could that be an issue?

There're too many configurations to post them all here. if you think you need more information, please tell me which parts and I will update my question.

migrated from serverfault.com Jan 30 '15 at 11:25

This question came from our site for system and network administrators.

  • auth failed => your IMAP client provided pair of username and password that doesn't match with your username and password stored in mysql – masegaloeh Jan 28 '15 at 9:26
  • @masegaloeh I double-, triple-checked my password and username and they are correct. There are so many places where it can go wrong - wrong encryption, missed parameters...I think I will just start again >_< – dayuloli Jan 28 '15 at 16:35
0

Make sure your mail client forces using TLS.

To debug you could also try to comment the disable_plaintext_auth option out. Always reload/restart postfix or dovecot when changing something.

  • How do I 'force' the client to use TLS? I am trying to connect to it using my phone, and I tried both SSL and TLS and it didn't work. I will try doing it again from scratch and checking after each step...even though that will taken me much longer! – dayuloli Jan 28 '15 at 16:34
  • Which client do you use? Mostly there is an connection option where you can choose SSL/TLS. – sme Jan 29 '15 at 15:28
  • I just use the one provided by my native Android phone. It let's me select something like 'SSL', 'SSL (Accept all certificates), 'TLS', 'TLS (Accept all certificates)'. And I tried them all already...Now I have reverted back to my old externally hosted mail server...since I was being a cowboy and losing email. I have decided now to host the mail server on its own machine and use a 'dummy' domain to test and make sure everything works – dayuloli Jan 29 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.