0

I've spent the last two days trying to get my computer working. It's a Dell Inspiron 15R SE.

I have Windows 7 Professional and Linux Mint installed.

I've tried the recovery disk for Windows and that just leaves me with a boot loop and a blue screen of death.

On the Linux side I've tried using boot-repair ( http://paste.ubuntu.com/9952105 ) but I still just get a no operating system message when trying to boot from the Hard Disk.

Here is the output of my partition info etc from Boot-repair: http://paste.ubuntu.com/9953024/

If anyone can point me in the right direction I'd be so grateful.

| improve this question | | | | |
0

Do you get to the grub menu, I assume you do not. I also assume that you do not get to a Windows 7 boot menu because you mention "no operating system" message.

I would boot into a Linux live CD, run sudo fdisk /dev/sda and toggle boot bit on the sda2 partition. You have two partitions that are bootable when you should only have one, reboot. You should now be able to get to Linux and Windows 7, assuming that grub is installed on sda5 - I cannot tell for sure, I assume it is not on sda2.

If you get the "no operating system" message, then I would boot into the live cd again, and toggle boot flag on sda5 and sda2 again, making sda5 not bootable and sda2 bootable.

| improve this answer | | | | |
0

I'm not an expert for this kind of problems, but it seams you don't have a usable bootloader (like GRUB) installed! I also guess that you finally killed your bootloader with the "recovery disk for windows"!
--> for the future: If you don't use only Windows forget the tools from Microsoft! They ignore every other system than Windows and so for the most time they are finally messing up your configuration completely. That's also the reason why you have to install Windows first on dualboot-systems.

I haven't worked nor tested boot-repair till now, but I would recommend SuperGrubDisk to find and start your installed systems and also restore/install GRUB.

| improve this answer | | | | |
0

Hi Thanks for your messages,

In the end what allowed me to get access to all my old partitions was this command:

sudo dmraid -E -r /dev/sda

It was the RAID that was interfering with all the recovery attempts.

After running this command all the boot disks started to run the recovery properly. First, I recovered windows and then linux using boot-repair after booting from the live CD.

What a relief!

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.