2

my system drives are based on these hardware parts

1: SSD 250 GB
2: HDD 1TB
3: External HDD 2TB

I use my SSD for Windows 8.1 and all other related stuff, like, installing software etc. The HDD is used for installing games on it, and the external HDD is, well, just an external HDD.

So what I wanted to do is, to install Linux Mint 17 next to Windows 8.1 Since I heard there might be problems with machines that run with UEFI, I searched for a tutorial to do it right.

I used this tutorial here. I shrunk my SSD by 60GB, started Linux Mint from USB and installed it.

According to the tutorial, I divided the free space into three parts

SWAP -> 4GB
EXT4 in path / -> 20GB
EXT4 in path /home -> 36GB

The tutorial said, I should install the bootloader in the partition that says efi. However, there was no such partition, so I created one by my own from the rest of the unused space I had. (Maybe, this was the problem)

I then installed Linux Mint, and can now use it without any problems. However, I can't get back into Windows 8.1.

When the computer starts and I hit F8 to select boot device, and I select the SSD where Win 8. is, I get the error message

This is not a bootable disk. Please insert a bootable floppy

Some people told me, that I need to select Win 8 out of the grub loader and not out of the device selector.

When I pressed ESC repeatedly the grub loader showed up, but only Linux Mint was in it.

What I then did, was the following: I booted into the live cd again (with USB Stick) and performed these commands

sudo add-apt-repository ppa:yannubuntu/boot-repair &&
sudo apt-get update &&
sudo apt-get install -y boot-repair &&
boot-repair

However, the only thing this did, was that I now have "Ubuntu" instead of Linux Mint in the bootloader, why so ever.

Then, I tried to update grub. This is the output

sudo update-grub2
[sudo] password for tzfrs: 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-44-generic
Found initrd image: /boot/initrd.img-3.13.0-44-generic
Found linux image: /boot/vmlinuz-3.13.0-37-generic
Found initrd image: /boot/initrd.img-3.13.0-37-generic
  No volume groups found
Adding boot menu entry for EFI firmware configuration
done

I also tried update-grub instead of update-grub2

This is my grub configuration file

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Then, I tried to add it manually, by following this tutorial, but I'm already stuck at Step 1 where I should find my EFI partition with this command

sudo parted /dev/sda print | grep -i efi

However, there is no output. I also changed /dev/sda to something else, but still nothing. When I type in df -aTh I don't even see anything called EFI. So, where exactly is this efi thingy so I can continue this tutorial?

This is the ouptut of df -aTh

Filesystem     Type             Size  Used Avail Use% Mounted on
/dev/sdb6      ext4              19G  6,8G   11G  40% /
proc           proc                0     0     0    - /proc
sysfs          sysfs               0     0     0    - /sys
none           tmpfs            4,0K     0  4,0K   0% /sys/fs/cgroup
none           fusectl             0     0     0    - /sys/fs/fuse/connections
none           debugfs             0     0     0    - /sys/kernel/debug
none           securityfs          0     0     0    - /sys/kernel/security
none           efivarfs            0     0     0    - /sys/firmware/efi/efivars
udev           devtmpfs         7,8G   12K  7,8G   1% /dev
devpts         devpts              0     0     0    - /dev/pts
tmpfs          tmpfs            1,6G  1,6M  1,6G   1% /run
none           tmpfs            5,0M     0  5,0M   0% /run/lock
none           tmpfs            7,9G   21M  7,8G   1% /run/shm
none           tmpfs            100M   12K  100M   1% /run/user
none           pstore              0     0     0    - /sys/fs/pstore
/dev/sdb7      ext4              36G 1009M   33G   3% /home
binfmt_misc    binfmt_misc         0     0     0    - /proc/sys/fs/binfmt_misc
systemd        cgroup              0     0     0    - /sys/fs/cgroup/systemd
gvfsd-fuse     fuse.gvfsd-fuse     0     0     0    - /run/user/1000/gvfs
/dev/sdc1      vfat              30G  1,5G   28G   6% /media/tzfrs/KINGSTON

So, does anyone know, how I can get Windows 8.1 again into my bootloader? I can see the SSD partition with Windows in Linux Mint, so it's def. still there.

1

I'm not an expert for boot-problems, but i'm afraid you are right and messed up the installation of the bootloader (GRUB) with the efi-partition!
I never had a problem with the installation on devices with efi. Just read the Release Notes and turn off secureBoot!

I would advise you to install GRUB with SuperGrubDisk in the MBR of the harddisk (in your case the SSD) where Windows and Linux is installed on (i would guess it is the first harddisk called "sda").
Or if this is to complicated and it is not too much work reinstall Linux and place the bootloader just on "sda"!


some advises for installation and dualboot-systems:

  • the swap-partition should be as much as the RAM-memory (for hibernation)
  • yes, i would separate the root-partition "/" (for system files and programs) and the home-partition "/home" (for your data and configurations); but if you need much space i would place root and swap on the SSD and home on the big HDD.
  • if it is possible and your hardware has enough power you should prefer a virtual machine: You can't destroy your main OS and work simultaneously with both systems; and VirtualBox is pretty easy to handle.
  • if you really want to work with a dualboot-system for a longer time or still have to run Windows native for some games i would recommend to store your files in the home-partition and if needed access your files within Windows via Ext2Fsd.
0

At first search all possibility and then only apply this.

Make live mint cd/usb make space , boot with live mint, install on separet part on hdd contains win 8.1, boot in to win 8.1 "restart" holding shift key goto command window,run diskpart, run select disk, run select vol contains mint, run active 1/2/3 (vol cotains mint. you are done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.