16

By default F10 on Xfce activates the window File menu and so cannot be used as a shortcut in any program.

I already looked in the Window Manager and Keyboard settings pages and no F10 key binding is listed.

How can I re-map/un-map this?

2 Answers 2

13

Xfce provides a way to disable the key binding from the Settings Editor.

This will work only for GTK+ 2 applications, given that "gtk-menu-bar-accel" has been deprecated in GTK+ 3 (since version 3.10). As a result, user might have no choice but to disable the key binding per application, which may also depend on which toolkit in use.

Go to Applications Menu > Settings > Settings Editor. Xfce 4.10 or newer provides another way to access by Settings Manager > Other - Settings Editor.

In the Settings Editor:

  • On the left, under "Channel", scroll down and select "xsettings"
  • On the right, under "Property | Type | Locked | Value", look for Gtk > MenuBarAccel
  • Double-click on the row of "MenuBarAccel" to edit this property
  • In the "Edit Property" dialog, delete the value F10 (leave it blank) and click Save.

The final step will disable the key binding for activating the menu bar.

Custom keys: User can also change the key binding to something else. For example, changing the value to <Control>F12 will re-map to Ctrl+F12 key combination to activate the menu. Try with any key bindings using <Alt> <Shift> and other keys. More clues are found under "Channel: xfce4-keyboard-shortcuts" and under "Property".

Restore to default: In the Settings Editor, click Reset button that is located at the right-most icon, either at near-bottom of window (Xfce 4.10 or newer) or, on top of "Property" column (Xfce 4.8).

Precaution (Xfce 4.8): In older Xfce, clicking Reset button will cause the entire row of "MenuBarAccel" to be removed at all. To avoid this, double-click on the row again and change the value to F10 to restore.

Name: /Gtk/MenuBarAccel
Type: String
Value: F10

In case user have accidentally deleted the property, create again the property as follows. Click New and re-register the property in the "New Property" dialog with the settings quoted as above.

Xfce can still disable the key binding for GTK+ 2 applications, such as Orage and Xournal. Given that many applications are now GTK+ 3, the setting will be less and less relevent in newer Xfce.

2
  • 1
    I have changed the value, but F10 is still working. I have to log out and in at least for changes to be applied, I guess, right? Jun 23, 2023 at 22:35
  • For xfce4-terminal, you need to disable F10 in the program Preferences (see answer below) even if you've disabled F10 globally in the Settings Editor as described here. Jul 21, 2023 at 3:02
11

There is also a setting for disabling this shortcut on Terminal Preferences -> Advanced:

enter image description here

2
  • 1
    Should be accepted answer.
    – orschiro
    May 17, 2019 at 18:41
  • 1
    This only works on xfce4-terminal, not on other programs.
    – dns
    Feb 24, 2021 at 19:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .