I have tried to install Ubuntu and ArchLinux on the machine and the installation went fine but the boot process fails with both system. In the case of Arch the boot doesn't even start. In the case of Ubuntu the boot either stuck on grub rescue console after a message of ``out of disk'' or grub is loaded but I can't load the system (stuck on kernel load for a huge period of time and finally reload grub menu). is the farthest I have gotten. I also tried Slax (which froze during loading) and XBMC Live (which froze as well).

I have a machine very similar to this. The main differences are: larger 320GB HD made by Toshiba with S.M.A.R.T technology and 1GB of memory.

  • Grub has two versions, grub2 and grub-legacy. Try both (fedora 14 use grub-legacy). Try also with lilo (available in Debian installer). Remember disconnect all USB disks. If all fail, the problem is hardware. Aug 6, 2011 at 8:07

1 Answer 1


This is just a guess, but have you tried emptying the disk by writing zero over everything or similar? It can just be that the disk has partitions in partition table, and Linux installer chokes on trying to understand them. Another thing worth doing is running diagnostics tool from the manufacturer of the hard drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.