5

When I connect to a device using Screen in terminal, if I open Nano text-editor it only takes up a fraction of the screen. How do I make it fullscreen?

  • How are you connecting to the device? – Barmar Jan 28 '15 at 17:20
  • over a USB to TTL serial cable. – user989990 Jan 28 '15 at 17:21
  • I mean what application are you using? – Barmar Jan 28 '15 at 17:21
  • terminator is the terminal program, screen is the program. – user989990 Jan 28 '15 at 17:22
  • Does this really only happen in screen? If you connect to the same device using a raw terminal, it uses the full screen? – Barmar Jan 28 '15 at 17:23
3

Before you connect to the device, use:

stty -a

and note the rows and columns values that it prints. After connecting to the device, use:

stty rows <rows> cols <cols>

where <rows> and <cols> are replaced with the values printed before connecting. Since you're not using a network protocol like ssh that can send this information to the device automatically, you need to do it by hand.

2

Even simpler than recording the size using stty would be to run the resize program on the remote device.

resize is a utility provided with xterm. It uses VT100 escape sequences (supported by Terminator and screen) to find the actual screen size and does the equivalent of

stty rows actual-rows cols actual-cols

and just typing

resize

seems simple enough.

0
mate-terminal --zoom 1.8 --hide-menubar --full-screen -e nano

Look at your terminal emulator, because options can be different. I do not know how to do it without X.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.