3

I'm running the latest version of Crunchbang 64-bit on a Dell E5510 notebook.
Installing my printer and scanner worked fine - I just used an existing Ubuntu tutorial. However, scanning without starting Simple-Scan as sudo produces an error message. My main account is listed as part of the group scanner, according to the output of less /etc/group. To my limited knowledge, this should suffice, shouldn't it? What more steps are necessary in order to run simple-scan without sudo?
Thanks in advance.

1 Answer 1

0

I found similar question asked on SU. Also this Ubuntu how-to could be useful. And there's a bug regarding permissions to access a scaner.

Summarizing this sources:

  • Add saned to the group which owns your scanner device: sudo adduser saned scanner. Note that device may be owned by different group, so use sane-find-scanner to determine the device and ls -al /dev/bus/usb/XXX/XXX to identify the group. Then add saned to this group.

There's not very secure way to run saned as root.

  • Add this line to /etc/rc.local (before exit 0): chmod -R a+w /dev/bus/usb

  • Edit/create the following file: /etc/xinetd.d/saned:

service saned { socket_type = stream server = /usr/sbin/saned protocol = tcp user = root group = root wait = no disable = no }

  • Edit /etc/default/saned: RUN_AS_USER=root and RUN=yes

  • Reboot.

10
  • I tried your first advice and got abc@crunchbang:~$ ls -al /dev/bus/usb/002/004 crw-rw-r-T 1 root lp 189, 131 Jan 28 17:09 /dev/bus/usb/002/004 as a result. Sorry for the dumb question, but what exactly is the group here?
    – T. K.
    Commented Jan 28, 2015 at 16:41
  • Group is lp here. To add saned to lp group run sudo adduser saned lp.
    – kirill-a
    Commented Jan 28, 2015 at 17:23
  • After following all steps the scanner works as it should. Could you, in simple terms, explain what was done here exactly?
    – T. K.
    Commented Jan 29, 2015 at 11:46
  • Service saned which works with scanner is started by inetd with user name "saned". To have access to it first you tried to add saned to be in the 'lp' group (which your device belongs to). But that didn't help because it seems that saned nor lp nor any other person has access to the device other than "root". By going through last steps you just tell xinetd to run saned as root. This 'bug' is a direct result from bug that sane does not have udev rules in place to give the device proper permissions when plugged in, resulting in the root:root ownership.
    – kirill-a
    Commented Jan 29, 2015 at 12:14
  • Thank you for the explanation. However, I was a bit too quick to say that everything worked properly - because it didn't the next time I rebooted the system. Thus, I checked all instructions once more and edited /etc/default/saned: RUN=yes. Now the problems seems resolved for good.
    – T. K.
    Commented Jan 30, 2015 at 12:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .