Output of running ifconfig on my system is:

eth3      Link encap:Ethernet  HWaddr 44:8a:5b:93:34:25  
          inet addr:  Bcast:  Mask:
          inet6 addr: 2002:ac20:1152:b:355b:2bc9:2556:1f47/64 Scope:Global
          inet6 addr: 2002:ac20:1152:b:6d65:3d7f:bb17:6aac/64 Scope:Global
          inet6 addr: fec0::b:859c:f9ad:8b79:ec69/64 Scope:Site
          inet6 addr: 2002:ac20:1152:b:f140:b5d1:22a9:844a/64 Scope:Global
          inet6 addr: fec0::b:f140:b5d1:22a9:844a/64 Scope:Site
          inet6 addr: 2002:ac20:1152:b:802c:9eed:86ea:55cd/64 Scope:Global
          inet6 addr: fec0::b:cdab:5e4d:71c8:cd3d/64 Scope:Site
          inet6 addr: 2002:ac20:1152:b:468a:5bff:fe93:3425/64 Scope:Global
          inet6 addr: 2002:ac20:1152:b:491:b025:26db:ea08/64 Scope:Global
          inet6 addr: 2002:ac20:1152:b:cdab:5e4d:71c8:cd3d/64 Scope:Global
          inet6 addr: fec0::b:355b:2bc9:2556:1f47/64 Scope:Site
          inet6 addr: fec0::b:802c:9eed:86ea:55cd/64 Scope:Site
          inet6 addr: fec0::b:468a:5bff:fe93:3425/64 Scope:Site
          inet6 addr: 2002:ac20:1152:b:859c:f9ad:8b79:ec69/64 Scope:Global
          inet6 addr: fec0::b:6d65:3d7f:bb17:6aac/64 Scope:Site
          inet6 addr: fec0::b:491:b025:26db:ea08/64 Scope:Site
          inet6 addr: fe80::468a:5bff:fe93:3425/64 Scope:Link
          RX packets:4482604 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1525330 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1237193702 (1.2 GB)  TX bytes:438402088 (438.4 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8973488 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8973488 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1042672397 (1.0 GB)  TX bytes:1042672397 (1.0 GB)

Why so many IPv6 addresses?


That happens because you have net.ipv6.conf.*.use_tempaddr set to 1. This enables RFC 4941 privacy addresses for the specified interface(s). RFC 4941 states that implementations MAY remove deprecated addresses, but most that I've seen don't. You can disable them via /proc or sysctl. I believe Linux generates a new one once per week, so it looks like your system has an uptime between seven and eight weeks. Your ether address prefix doesn't seem to be registered to a vendor so it may have been randomly generated (possibly because it's virtual?).

IPv6 SLAAC addresses by default have the ether address of the NIC included as part of the address so it's a good idea to leave them enabled on anything that is physical and connects to the Internet because it becomes a globally unique tracking identifier. I generally disable it on virtual instances because they usually have a short lifetime and are already not real.


Maybe this can help you: https://stackoverflow.com/questions/9886711/why-ipv6-allows-a-single-interface-with-multiple-addresses

As I understand, you get IPv6 addresses from routers. Therefore it would be interesting to know more about the network your computer is connected to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.