28

My laptop (a Toshiba Sattelite) runs far too bright, even in the ambient light from outside in the day, and I need to be able to dim it below its minimum setting.

   ~#cat /sys/class/backlight/acpi_video0/brightness
   ~#0

Setting it below 0 will not work, and apps like flux even with some hackery to force it to night mode via script by rolling the timezone fails to do too much and leave colours of course yellowed.

Is there some sort of method to set it below its minimum somehow? (uses some integrated nvidia card by the way)

Is there a program I'm missing that will artificially dim it by overlaying transparent black?

6
  • see man xgamma - or otherwise install it if you don't have the package already. Else look at adjusting the RGB settings w/ xrandr (which is all xgamma does anyway). – mikeserv Jan 28 '15 at 6:10
  • @mikeserv, amazing, but it seems to affect white far less than the other colours. The background of this site is quite an eye-sore compared to the now fairly dimmed firefox theme that I have (of greens and oranges) I'll try to see muck with it more. xgamma -gamma 0.4 I'd used for example. – Alex. Jan 28 '15 at 6:14
  • also have a look at redshift. – michas Jan 28 '15 at 6:15
  • @mikeserv Excellent, xrandr with --brightness 0.5 did the job to dim the white. THANK YOU. very odd this wasn't easier to find, few have asked, maybe my eyes are just more sensitive than the average joe's. Write an answer below? :) – Alex. Jan 28 '15 at 6:22
  • Thanks for asking this question - and the followup comment on --brightness. It had been a while since I hunted this info down and it was a little foggy, but my eyes thank you - they were already a little achy when I found your question and I needed the reminder that there was something I could do about it. – mikeserv Jan 28 '15 at 6:48
35

With xrandr you can affect the gamma and brightness of a display by altering RGB values.

From man xrandr:

  • --brightness

    Multiply the gamma values on the crtc currently attached to the output to specified floating value. Useful for overly bright or overly dim outputs. However, this is a software only modification, if your hardware has support to actually change the brightness, you will probably prefer to use xbacklight.

I can use it like:

xrandr --output DVI-1 --brightness .7

There is also the xgamma package, which does much of the same, but...

  • man xgamma:

    Note that the xgamma utility is obsolete and deficient, xrandr should be used with drivers that support the XRandr extension.

I can use it like:

xgamma -gamma .7
3
  • 1
    What about Wayland? – lkraav Jul 16 '16 at 20:51
  • 3
    To know correct output (if DVI-1 not works) use xrandr -q – Pavel Mar 27 '17 at 22:57
  • See also this very interesting and helpful post about xrandr and how you can use it to replicate the functionality of the Night Light feature, while also dimming the screen: askubuntu.com/questions/1003101/… – GDP2 Oct 9 '20 at 4:04
0

This answer is specific to those who may be running Gnome and Wayland, but similar Accessibility / Zoom features may exist elsewhere (iOS being an unrelated example).

TLDR: Settings > Accessibility > Zoom

Here is a last resort for anyone who tried the above and was unsuccessful.

My setup: Gnome, Wayland, Fedora 33, Dell XPS 15 9500

You should be able to find in the Zoom feature via Settings > Accessibility > “Seeing” > Zoom. Here you should be able to modify brightness, contrast, color according to your preferences. Set magnification to 1.0 (unless you want your focus to follow the mouse around). If you run into weird lingering visual artifacts from the mouse you can enable the crosshair and customize the color to be transparent (I also have thickness and length set to the minimum, and unchecked the “overlaps mouse cursor”, although I’m not sure whether these settings matter).

Lastly, for convenience and easy toggling, via Settings > Keyboard Shortcuts there should be an option for “Turn zoom on or off” which you can map to an appropriate key binding (mine is set to “Shift + Monitor brightness down”). YMMV!

Credit goes to Bastien: https://bugzilla.gnome.org/show_bug.cgi?id=741224#c42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.