2

I have manjaro linux and I am trying to disable dpms for good. I have xautolock which enables my screenlocker (i3lock) after some time which also puts my monitors to sleep.

I know that I "can" disable DPMS with xset -dpms but after a restart or suspend-period it gets enabled again (xset q for checking).

I have some scripts which are executed (hooked into systemd) after waking up from suspend or after rebooting and I already added xset -dpms to them, but that doesnt work.

I also have xscreensaver deinstalled from my system, so this cant be a reasion for DPMS always being reenabled.

Sometimes it even gets reenabled some minutes after I executed xset -dpms

So, what could be the reason for DPMS always beeing reenabled? Which program/daemon could be the reason for this behaviour?

1

I've managed to prevent DPMS from blanking with this command:

xset dpms 0 0 0 && xset s noblank && xset s off

It should be autostarted one way or another when you start your DE/WM but it persists suspension.

  • Well, it doesnt really disables DPMS, but its behaviour :) Seems like its working, I will keep an eye on it if somehow it will be enabled again (meaning the thresholds be set to > 0). But you have no idea what could be the cause of this behaviour I mentioned in my question? – degill Jan 27 '15 at 18:13
  • You're right, this doesn't disable DPMS - it prevents DPMS from blanking (I've edited the answer accordingly). To the best of my knowledge, DPMS can't be disabled or uninstalled by any conventional means. But DPMS is only active when no screensaver (xscreensaver or similar) is installed. So the best way to disable it, would actually be to keep xscreensaver installed. Second option is to prevent DPMS from blanking. Above command has managed to do that for me for the past couple of years ... – MajorBriggs Jan 27 '15 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.