2

All mails suddenly stopped sending, here is the maillog:

Jan 26 17:02:20 vm2745 sendmail[3544]: My unqualified host name (Centos) unknown; sleeping for retry
Jan 26 17:03:20 vm2745 sendmail[3544]: unable to qualify my own domain name (Centos) -- using short name
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPA003544: Authentication-Warning: Centos: apache set sender to [email protected] using -f
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPA003544: [email protected], size=470, class=0, nrcpts=1, msgid=, relay=apache@localhost
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPA003544: [email protected], [email protected] (48/48), delay=00:01:00, xdelay=00:00:00, mailer=relay, pri=30470, relay=[127.0.0.1] [127.0.0.1], dsn=5.0.0, stat=Service unavailable
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPA003544: t0QG2KPB003544: DSN: Service unavailable
Jan 26 17:03:20 vm2745 sendmail[3545]: t0QG3K4Q003545: Centos [127.0.0.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPB003544: [email protected], delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31494, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPB003544: t0QG2KPC003544: return to sender: Service unavailable
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPC003544: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32518, relay=[127.0.0.1], dsn=5.0.0, stat=Service unavailable
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPB003544: Losing ./qft0QG2KPB003544: savemail panic
Jan 26 17:03:20 vm2745 sendmail[3544]: t0QG2KPB003544: SYSERR(apache): savemail: cannot save rejected email anywhere

hosts:

127.0.0.1       Centos localhost
::1     localhost6.localdomain6 localhost6

hosts.allow:

ALL : 127.0.0.1, 212.226.x.x, 10.10.10. 
sendmail : ALL
sendmail : localhost
popa3d : ALL

hosts.deny:

ALL:ALL

/etc/mail/access:

Connect:localhost.localdomain       RELAY
Connect:localhost           RELAY
Connect:127.0.0.1           RELAY

What's wrong?

1 Answer 1

2

Removed Centos from hosts and added this line:

mydomain.com.ip.address mydomain.com

Now it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .