0

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Technical_Notes/deployment.html

According to this, /etc/inittab has been deprecated. As suggested from this I created a /etc/init/serial-ttyS2.conf. After that I has to make the service start with the following command:

[root@sbc-l1c-pcc-00 ~]# initctl start serial-ttyS2

[root@sbc-l1c-pcc-00 ~]# ps aux | grep tty

root 7779 0.0 0.0 2016 536 ttyS2 Ss+ 13:38 0:00 /sbin/agetty/dev/ttyS2 9600 vt100

However when I try to connect no login prompt pop out, just a blank screen. I tried to restarted the serial-ttyS2 while the screen was still open and the login screen came out. And I have to do it every time I need to to connect. Does somebody have a clue why?

1

Assuming that the missing space /sbin/agetty/dev/ttyS2 is not real, otherwise you have serious issues.

It's likely that you haven't asked agetty to monitor Data Carrier Detect. When asserted DCD means that there is a session in progress. DCD in turn requires DTR to be present, as Data Terminal Ready when asserted means that the other RS-232 lines from the terminal are not invalid.

Because of the lack of knowledge of the DCD (ie: user at terminal) status agetty doesn't know when a user connects, and thus can't present a prompt. Instead it waits for the user to press Return -- see the description of the -L option in man agetty for more information on this point.

Assuming you've got a correctly-cabled null-modem cable:

/sbin/agetty --8bits --flow-control -L=never ttyS0 9600

Otherwise you'll just have to live with people pressing Return.

You might find some hints in this blog post about serial terminals and Fedora 20.

  • Hello, Thank for the answer and before investigating more I would like to understand what you mean with the first sentence "Assuming that the missing space /sbin/agetty/dev/ttyS2 is not real, otherwise you have serious issues". – thenandnow Jan 28 '15 at 9:47
  • It should be /sbin/agetty /dev/ttyS2 – vk5tu Feb 9 '15 at 4:57
  • I see your point, sorry the output got all stuck together. Anyway it works, Simply I don't know why the first few times it wasn't answering to any keyboard input, until it did and instead of reloading the service I just have to press any key. Thank anyway – thenandnow Feb 9 '15 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.