2

My laptop restarts everytime I close the lid and open it up again.

In System Settings->Power there is no option for what the laptop should do when the lid is closed.

The laptop never did this before but I got this problem after a fresh Debian install.

Also when hibernate it seams to restart when it comes out of hibernation.

edit: My laptop is a Dell Latitude e6410 and I found out that I probably have this problem after a bios update to the newest firmware.

Debian version 7.8

lspci output: VGA compatible controller: NVIDIA Corporation GT218 [NVS 3100M] (rev a2) (prog-if 00 [VGA controller])

1
  • What laptop model and OS version are you using, with what graphics? (use lspci -v and edit the answer into your question). It could be that it is trying to suspend, and restarts instead.
    – Wilf
    Commented Jan 23, 2015 at 17:55

1 Answer 1

2

Restart on closing the lid is not the default behavior of any distro I know of. That said, this is likely a more serious issue like a graphics card driver problem.

First thing I would try is using a newer Kernel. PopOS comes with newer ones preinstalled and Manjaro Settings has an easy GUI to select a newer Kernel. If your laptop is less than 3 years old, you may likely benefit from newer kernels, compared to what Ubuntu LTS ships with. Switching kernels is usually safe, as you can go select your previously installed kernel in the bootloader screen.

Make sure to check the system logs for any errors before doing anything destructive.

If you suspect it's your graphics, try going into your bios setup screen (usually F2 on boot) and disabling switchable graphics or the mux switch. If that setting doesn't exist, then try installing the other drivers for your graphics card... there are usually two options for discrete graphics cards. You can also change your sleep mode and disable problematic new Power Saving features which may cause instability.

1
  • I didn`t found any of those options in my bios Commented Jan 24, 2015 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .