5

I use PhpStorm. I use x2go and xpra for connect to remote machine with launched phpstorm.

If on terminal-system installed any desktop environment, exclude xfce4 - PhpStorm hotkeys work perfectly.

If installed xfce4 on terminal-system - some hotkeys in PhpStorm not work (Shift+F6, Ctrl+Alt+, Ctrl+Alt+)

On xfce4 window-manager and keyboard-manager turn off all keyboard shortcuts similar to PhpStorm hotkeys.

PhpStorm launched on xpra display on remote computer. Xpra session attached to x2go-session. My terminal computer connected to remote computer over x2goclient

2

2 Answers 2

6

They're probably used by the window manager. Check Settings > Window Manager > Keyboard.

4
  • Yes. Problem solved. After change keys in windows manager and Keyboard manager, need relogin for correct work hot keys in my applications. Jan 26, 2015 at 12:13
  • Ohh. No. Problem is still. After enter to xfce settings (I dont run window manager settings, i set some changes in session manager) - hot keys stopped worked in my applications. What is devil? Jan 26, 2015 at 12:55
  • I was getting weird behaviour when using Ctrl-Alt-< in Emacs, removing all the shortcuts fixed that, thanks!
    – dolzenko
    Aug 14, 2015 at 13:52
  • Helped me with Ubuntu. Windows-moving ALT+F8 and ALT+F7 were getting in the way
    – userfuser
    Feb 10, 2016 at 12:16
2

in Settings > Settings Manager > Settings Editor > xfce4-keyboad-shortcut , find left_workspace_key and right_workspace_key, remove it (select it and click on reset).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.