1

I've recently in installed mint 17 on my pc.

$ parted -l
Model: ATA PLEXTOR PX-256M5 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End    Size   Type      File system  Flags
 1      1049kB  256MB  255MB  primary   ext2         boot
 2      257MB   256GB  256GB  extended
 5      257MB   256GB  256GB  logical                lvm


Model: ATA SAMSUNG HD103SJ (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  1000GB  1000GB  primary  ext3


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/mint--vg-root: 252GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End    Size   File system  Flags
 1      0.00B  252GB  252GB  ext4


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/mint--vg-swap_1: 4291MB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system     Flags
 1      0.00B  4291MB  4291MB  linux-swap(v1)

The ATA PLEXTOR PX-256M5 disk did have windows 8 on it at before but it's been reformatted and should be completely gone, it now has the linux mint install on it.

The TA SAMSUNG HD103SJ disk did have windows 7 on it so I suspect it is something to do with this disk. Mint automatically mounts this disk (it doesn't have an fstab entry).

I've successfully manually created just a partition on the disk using fdisk and then mkfs, but when I restart my pc I still see the windows 7 option.

Can anyone tell me what I am missing?

  • So you left out the part "When I installed Mint 17, I had Windows 7 installed too. Then I deleted Windows 7." – Xen2050 Jan 22 '15 at 3:37
  • @Xen2050 That'd be the 3rd and 2nd from the bottom paragraphs, starting with "the TA SAMSUNG..." – derobert Jan 22 '15 at 18:03
  • It sounded like it had Windows 7 on it sometime in the distant past, not when Mint was installed (so Mint was being nice & creating a Windows 7 GRUB entry) – Xen2050 Jan 22 '15 at 18:14
3

It turns out that I needed to run the following:

sudo update-grub

This updated my /boot/grub/grub.cfg file and got rid of the windows 7 option.

1

Grub's menu comes from a configuration file, not by scanning hardware. However, the configuration file can be created by scanning hardware, which you would want to do after you've changed partitions around.

The command to do this is either grub-mkconfig (Debian derived) or grub2-mkconfig (Fedora derived). I presume Mint would be the former but in any case, only one or the other will actually be installed.

Double check you have an existing /boot/grub2/grub.cfg. If not, there should be a grub.cfg somewhere in /boot or a grub subdirectory. Back that up (eg. cp grub.cfg grub.cfg.bk). You then need to su root and run grub-mkconfig (or grub2-...); this will print to standard out. This is just to make sure it works. If so:

grub-mkconfig > /etc/grub2/grub.cfg

Presuming that's the right path. The reason I said to use su and not sudo here is because of the redirection (>). This time there will be much less output, just stuff like Found linux image: etc.

When you reboot, the options should be updated. If for some reason the new config doesn't work for anything, you'll need to boot a live CD and replace grub.cfg with the backup you made.

  • Thanks, your advice lead me to the correct answer which I've posted in this thread. Had to run update-grub. – bplus Jan 21 '15 at 21:19
0

If, as it seems from the info you gave, you have no other OS installed than Linux, an option would be to disable os-prober.

Two ways of doing this:

  • Set GRUB_DISABLE_OS_PROBER=true in your grub defaults file (/etc/default/grub? - Not sure on Mint)
  • Remove the os-prober package (if it's missing, grub-mkconfig will skip that part)

What may be happening is that os-prober is mistakenly thinking there is still Win7 on that disk due to some sectors still containing whatever signature it checks for. One other solution, if there is no important data on that drive yet (since you seem to hint it was recently repartitioned and formatted), would be to zero the first 10Mb or so (e.g. dd if=/dev/zero of=/dev/sdb count=1 bs=10M), then reinstall a boot label, repartition and reformat.

Inspecting the /boot/.../grub.cfg should tell you which device is being detected as having Win 7 before you try any of this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.