4

I am trying to install debian on Virtual box using debian-7.8.0-amd64-netinst.iso When I insert my proxy server http://192.168.2.2:3128, it says the installer failed to access the mirror. However on my host operating system (Ubuntu 14.04), with wireshark open, I can see the request is indeed going out and returning a list of hashes and gz files, so I believe I have virtual box configured correctly (using NAT mode).

When I switch into tty4 (which shows the error console), it says

"Failed to fetch http://ftp.uk.debian.org/debian/dists/wheezy/main/i18n/Translation-en Cannot initiate the connection to 3128:80 (0.0.12.56). - connect (22: Invalid argument)

So I believe it is failing to parse the host portion of the proxy server and it thinks the port is the ip. Is my understanding correct?

I have also tried

export http_proxy="192.168.2.2:3128"
export https_proxy="192.168.2.2:3128"
export ftp_proxy="192.168.2.2:3128"

Other things I found was to add the proxy into /etc/apt/apt.conf, but as this is still at the installation stage, the apt directory doesn't exist.

How can I correctly specify my proxy?

  • 1
    This sounds like a bug, but a slightly surprising one, if it is a bug. One workaround is to try to install without accessing the internet and fix up the network connection later. I'm not sure if that is possible with a netinst though. If it does install, it would be a pretty minimal system. – Faheem Mitha Jan 21 '15 at 17:32
  • 2
    What happens if you use http://192.168.2.2:3128/, with a slash at the end? – muru Jan 21 '15 at 17:37
  • AARRggh, that appears to have fixed the problem. Thanks If you place this as an answer, I can mark it as answered. – A G Jan 21 '15 at 17:45
  • 1
    Hah, that's pretty nutty. @AG, I recommend you submit a bug report about this. Installation reports are requested, anyway. – Faheem Mitha Jan 21 '15 at 17:47
  • @AG which one worked? The / or installing without internet? O.o – muru Jan 21 '15 at 17:48
7

Try http://192.168.2.2:3128/ with a trailing slash.

Without examining the debian-installer code, I can't say why it works, and from force of habit I have always entered the proxy server that way (even when using hostnames).

  • 1
    Good habits die hard... ;-) – Fabby Jan 21 '15 at 18:06
  • export http_proxy="localhost:3128" won't work and export http_proxy="http://127.0.0.1:3128/" will work, so we need add http://, thanks for the tip – Sérgio Apr 20 '18 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.