2

If I log on from a RHEL 6.5/GNOME notebook via SSH using gnome-terminal to an OpenBSD install, the UTF-8 support is OK.

But if I use OpenBSD / fvwm2 / xterm locally, not via SSH, then it just misses the UTF-8 support. I wanted to write: "árvíztűrő tükörfúrógép", I got this:

enter image description here

opening it with vi I got this:

enter image description here

When the installer asked me to select language, I choosed "HU", the "árvíztűrő tükörfúrógép" is a usual test..

Question: How can I enable UTF-8 support to the xterm?

1
  • What is your LANG variable set to? Did you start xterm with -u8? The character code points shown are consistent with ISO-8859-2. Jan 21 '15 at 15:00
1

Read the FAQ, especially http://www.openbsd.org/faq/faq8.html#locales, where it says:

If logging in via xdm(1) add a line such as

export LC_CTYPE="en_US.UTF-8"

to ~/.xsession before starting the window manager (see the section on customizing X for details). This example enables the Unicode (UTF-8) character set and will also cause applications such as xterm(1) to enable UTF-8 mode by default.

There also is uxterm(1), a wrapper around xterm that allows you to use UTF-8 without changing your locale.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy