0

As my first step downloaded vlc-2.1.5.tar.xz. after extracting ran "./configure" there comes this monster

"configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error."

unable to figure out what went wrong ? Even a hint is appreciated :)

  • The error says it all. lua is a separate tool - and as such requires installation if you want to make use of it (there is probably a package you can install from yum). If you don't think you need lua with vlc, then just run configure --without-lua. – Drav Sloan Jan 20 '15 at 12:14
  • i have to work on a offline system. Even disabling the "lua" is followed by multiple Errors – Ksk Jan 20 '15 at 12:25
0

Run lua -v to ensure that you have installed it.

Also you need Lua header/library files lua-devel: link

source

  • lua -v Lua 5.1.4 Copyright (C) 1994-2008 Lua.org, PUC-Rio Its already present – Ksk Jan 20 '15 at 12:22
  • Then you need lua-devel package – kirill-a Jan 20 '15 at 12:31
  • I've downloaded the following "lua-devel-5.1.4-1.el6.x86_64.rpm,lua-devel-5.1.4-1.el6.i686.rpm" Still the Same error as above :( – Ksk Jan 20 '15 at 12:39
  • Can you try lua-devel-5.1.4-4.1.el6.i686.rpm, lua-devel-5.1.4-4.1.el6.x86_64.rpm ? – kirill-a Jan 20 '15 at 14:07
  • Hey it worked :) But gave room for a new one --------------checking for AVCODEC... no configure: error: No package 'libavcodec' found No package 'libavutil' found. Pass --disable-avcodec to ignore this error. – Ksk Jan 21 '15 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.