0

Some of the context might not be relevant to the problem so feel free to skim through the rest of this post but essentially what I'm doing is trying to install an operating system onto the KAOS partition in the picture.

Partition Table

Hardware

OK so I'm on a Lenovo Yoga Ultrabook 13 (specs) and I'd rather keep Windows since I read online that I'd be having further problems once I finish this headache (mainly that the wifi is going to be screwed and stuff but I'm prepared for that).

Constraints

In order to keep the original setup intact while creating a new partition I had to do a little bit of magic because all the various partitions can somehow get out of sync or something if you're not careful.

tl;dr: I was VERY careful and I believe that my problem is related to the flash drive and not the partition setup.

Options

I've tried to install DeepinOS, openSUSE and KaOS and have had various different error messages which returned no relevant search results until I found this article. Which has a plausible explanation for my problems.

Diagnostics

I believe the usb drive is trying to use the wrong partition and that I need to specify in some config file exactly which partition I wish to use.

This makes sense since the

  1. openSUSE error came after I got a dialog box asking me to specify some path (the default is "/" and according to guides you're supposed to hit enter and things happen, I got some red box asking me to verify installation media).
  2. KaOS error said:

ERROR: Root device mounted successfully but /sbin/init does not exist.

Bailing out, you are on your own. Good luck.

Shortcomings

The one thing about that explanation that makes no sense is that these various installations have never tried to override anything (or indeed write anything). I'm sorry for not giving a more detailed description of the errors but I'm sick of restarting my computer and...

Other

... I've created bootable USB sticks with three different flash drives and 3-4 different tools (unetbootin, UUI, some windows only tool and the SUSE tool). I've both formatted and prepared them on my Linux Mint workstation and the windows laptop (as well as troubleshooted (troubleshot?) some other aspects of the process such as making sure the ISO's are OK etc).

I've had several problems with the flash drives, especially at first. However although none of my installation attempts has gotten farther than the first step of the installation process that seems to be a symptom of some other problem.

Summary

I will be completely content if anyone can help me get a working dualboot setup with any of the following OSes (based on screenshots and random biases so I'm pretty open to suggestions if there is some easy alternative although I'm guessing choice of OS is not related to the problem).

List of OSes:

  • Arch (I might be able to do this one myself thanks to their superb wiki)
  • Bodhi
  • Deepin
  • Elementary
  • openSUSE
  • KaOS
  • Pinguy

I'll be stalking this post since I'd really prefer to have access to linux in school so please ask me if you need anything clarified and please help me :(

0
  1. The first problem some windows pcs have is that they have secureboot enabled by default which makes booting up another os impossible.You need disable secureboot in the efi/bios(can't help you more with this problem because i use mac-hardware).

2.I like to know to which particular error you got in elementary os(the os i use),Did you try Luna or Freya?Did you get to the grub?And do you have some kind of boot loader installed?

3.Making a bootable USB,not every USB can boot a OS. Minimum 4gb USB (just use the best one you got!).Make sure you're USB is erased and formatted in ms-dos fatt(fat32).The program you should use to transfer the iso to USB is Startup disk creator, it's a ubuntu program it should work fine on you're linux mint workstation.

|improve this answer|||||
  • I finally managed to figure it out using dd and the internet – Pawnda Jan 22 '15 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.