3

I'm running elementary OS Freya Beta (under the hood: Ubuntu 14.04) and I need to edit the startup of a certain application to prevent it from running. The startup applications GUI window is still under work, it seems, so is there a way for me to add or edit an application manually from the session's startup applications for my user?

I've crawled all throughout gconf settings and dconf setting, but can't find a list of startup applications that the underlying mechanism uses. I've also ran find ~ -iname "*startup*" but didn't find anything useful.

How are GNOME/Pantheon session applications started, and how can I manually edit this list?

4

Oops a accidently gave you the Luna code. I upgraded the my system and afterwords used the ubuntu 14.04 code, it did not work, maybe because of gtk 3.14 upgrade(I should have tried it before upgrading).

Luckily I found something that did work.

Type this in the terminal: gnome-session-properties

Type in your password, a application will appear.

  • 1
    Yep, that's it! Unfortunately, it seems that the Elementary OS dialog doesn't show things unless they're disabled. After disabling the ones I was looking for in GNOME Session Properties, they showed up in the Elementary OS dialog. – Naftuli Kay Jan 21 '15 at 0:09
0

The GUI startup works fine on mine freya. Maybe the application you talking about is on hidden list.To get the hidden list on the starup GUI type this in the terminal:

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

The hidden apps should now be visible in startup GUI.

P.S. Be careful not to edit or remove any apps necessary to the OS.

Source: http://howtoelementaryos.org/how-to-display-hidden-auto-start-entries-in-elementary-os

  • 1
    I've run your sed and still nothing shows up in Freya in System Settings/Applications/Startup. Can you apt-get upgrade and let me know what you're seeing? – Naftuli Kay Jan 20 '15 at 19:02
  • check my next answer. – Bergkamp Jan 20 '15 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.