0

I have setup a small home server / NAS running Debian 7. The server is connected directly to the router with a static IP set in the router's control panel. There are no port forwarding rules set for the server machine. The server has been running fine for over two weeks, providing a samba share and a Plex service to the home network. Last week I wanted to use it to wake other devices in the house, so I installed the ethtool and ethwreake packages to do so. After those installs, when the server is attached to the router (or indirectly via a switch), it makes the internet connection drop randomly, for about 1-2 minutes. After this time, the connections returns and I can ping google.com for about 20-30 seconds, and that keeps repeating forever. I have absolutely no idea what could be causing this. How can a machine make the internet connection drop for the entire network? The only thing I could think of is some king of packet flooding, and the router can't keep up with the requests and reboots itself or something like that. This has happened before on another Debian install, and I had to reinstall the OS entirely since I couldn't find a solution. When I disconnect the server to the network, the connection returns after about 1 minute. Is there some kind of test I could do to find the cause, or do I have to clean install Debian again?

migrated from serverfault.com Jan 18 '15 at 13:49

This question came from our site for system and network administrators.

  • You could try watching the network with wireshark when this happens (ideally from another machine, if it involves the server getting connected). – goldilocks Jan 18 '15 at 15:45
0

It sounds like what happens when two devices on the same network have been given the same IP address. Check both devices and ensure that they have different IP addresses.

  • I set a static IP of 192.168.1.51. The router's DHCP service assigns IPs from 192.168.1.101 to 192.168.1.150, so it should work. No other devices share the same IP address, but it still doesn't work. – Nicolas Realini Jan 18 '15 at 14:48
  • Nevermind, setting the IP from the server directly and not from the router resolved the issue. Thanks for the help. – Nicolas Realini Jan 18 '15 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.