1

my flatmate crashed her windows installation badly. And of course she just had 1 partition C: on it and no backup. And of course there are very important documents on the HDD.

I tried to recover those using GParted and a Ubuntu 14.10 LiveCD.

While mounting an USB HDD works as expected, I can not access the data on the X: partition of the laptops hard disc drive (ntfs). [+ some manufactorer partitions] It is just empty and gparted tells me, there is nothing on this HDD at all. I am not buying this, since for example windows starts to boot. I used photorec to have a closer look and could reconstruct several pictures and documents, which should not be possible from an empty hard drive (even though photorec is used for deleted data actually).

As far as I understood the main problem may be the fact that this partition is the one with windows installed on it. Is there way to access it and get to the data? I tried mounting it new several times.

Outputs from parted and gdisk:

Model: ATA WDC WD5000BEVT-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type      File system  Flags
 1      1049kB  211MB  210MB   primary   ntfs         boot
 2      211MB   453GB  453GB   primary   ntfs
 3      453GB   484GB  31,1GB  extended               lba
 5      453GB   484GB  31,1GB  logical   ntfs
 4      484GB   500GB  15,8GB  primary   ntfs         diag


Model: Intenso External USB 3.0 (scsi)
Disk /dev/sdd: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  ntfs


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Model: HL-DT-ST DVDRAM GT30N (scsi)                                      
Disk /dev/sr0: 1163MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number  Start   End     Size    File system  Name   Flags
 1      2048B   6143B   4096B                Apple
 2      1152MB  1155MB  2327kB    



ubuntu@ubuntu:~$ sudo gdisk /dev/sda2
GPT fdisk (gdisk) version 0.8.8

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
typing 'q' if you don't want to convert your MBR partitions
to GPT format!
***************************************************************

Exact type match not found for type code 0A00; assigning type code for
'Linux filesystem'
Exact type match not found for type code 6900; assigning type code for
'Linux filesystem'
Exact type match not found for type code 6D00; assigning type code for
'Linux filesystem'
Exact type match not found for type code 6600; assigning type code for
'Linux filesystem'

Warning! Secondary partition table overlaps the last partition by
2804196767 blocks!
You will need to delete this partition or resize it in another utility.

Additional info: I used the Win7 DVD to enter the CMD terminal. Using it, the partition E: is empty. Or at least is shown empty. I dont know how the laptop still tries to boot windows if the hard drive is shown empty, but that is an idicator for servere problems with the disc, at least I guess so.

EDIT: output of lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk
├─sda1   8:1    0   200M  0 part
├─sda2   8:2    0 421.8G  0 part /media/ubuntu/D888D69B88D67788
├─sda3   8:3    0     1K  0 part
├─sda4   8:4    0  14.8G  0 part
└─sda5   8:5    0    29G  0 part
sr0     11:0    1   1.1G  0 rom  /cdrom
loop0    7:0    0     1G  1 loop /rofs
  • What is the output of lsblk ? – No Time Jan 18 '15 at 3:26
  • I put the output in the original post – user49017 Jan 18 '15 at 10:53
  • Before you do anything else. Make a backup of the disk. Not a file backup but a raw dump of the whole disk. (e.g. boot from a liveCD and dd the disks content to another disk or via netcat over the network). Only then attempt to modify the original. That way you can always revert if something appears to be a wrong move. – Hennes Jan 18 '15 at 11:57
  • Also, windows weirdness is often best solved from within windows. after making the backup boot again from the windows 7 DVD, go back to the command prompt and run a fsck (chkdsk). – Hennes Jan 18 '15 at 12:00
  • As I said before (I think) there is nothing to backup using the LiveCD, the partition is shown as being empty. I tried various methods of copying. – user49017 Jan 18 '15 at 12:17
0

Personally, it seems the entire hard drive failed, or the entire hard drive is corrupt. At any rate, I've experienced this before. The files are impossible to access.

  • 1
    I fear that may be the problem. But impossible is a very unpleasant word, using Photorec I could reconstruct about 15.000 pictures and documents (after deleting everything below 10k), therefore at least some is safed. But this also means some sorting and renaming. But not for me. – user49017 Jan 18 '15 at 10:57
  • @user49017 ok. Well, that's good. Let this be a lesson to your friend. Always back it up. – Thomas Streiff Jan 18 '15 at 15:56
  • That is what I told her. I had a hdd crash about 12 years ago, since then I backup at least all the important information. So, nevertheless, I used the recovery on her lenovo to restore the system. Seems like I got most of the important stuff recovered, rest is now up to her. At least she has an usb drive now and may backup data... – user49017 Jan 18 '15 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.