1

I bought a 1 TB hard disk from my friend to back up my files but when I tried to copy 150 GB of data to the hard disk, during the last 5MB my laptop shut down due to power loss. After power came back it boots normally but doesn't allow me to access the hard disk, I can't open it in Windows or Ubuntu. I tried Kaspersky virus removal tool to the clear virus and also the following:

$ sudo -i
# apt-get update
# apt-get install --reinstall exfat-fuse exfat-utils 
# mkdir /media/user/exfat
# chmod -Rf 777 /media/user/exfat
# fdisk -l
%%Assuming the external drive partition is /dev/sdc1
# mount -t exfat /dev/sdc1 /media/user/exfat

Which is the command to change an un-accessible drive to accessible but in my case it shows:

FUSE exfat 1.0.1
ERROR: failed to open `/dev/sdc1'.

How can I access it?

  • It's just the 1 TB drive that's corrupted, right? Your laptop's drive is still ok? – PM 2Ring Jan 17 '15 at 13:55
1

Hard disk filesystem may be corrupted. Install gparted:

sudo apt-get install gparted

open it:

gparted-pkexec

and then check the hard drive partitions. Be sure it's the correct disk: editing it will wipe out data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.