1

I'm very new to Linux and the solution might be easy so excuse me for that.

I'm trying to run an application called EnCase Remote Recovery, which basically takes a remote image of a system. In order to that, a "servlet" must be deployed on the remote machine. I don't care if the servlet started automatically or manually.

Here is what the guide says: (P.S: the servlet name is enlinuxpc)

  • Method 1: To start it manually:
    • 1.a: Copy the servlet to the machine (Done that).
    • 1.b Insert the following before the STARTX command:LOAD

I have no idea what that means and as far as I know STARTX is something for GUI. I tried executing this: STARTX LOAD enlinuxpc and what I get is this:

/usr/bin/xterm: No absolute path found for shell: LOAD
xinit: connection to x server lost
  • Method 2: Starting it using xinetd

    • 2.a: Create a configuration file named enlinuxpc in the /etc/xinetd.d directory.
    • 2.b: Using a text editor such as vi, insert the following text into the file, then save and close it.

      service enlinuxpc

      {
      socket_type = stream
      protocol = tcp
      port = 4445
      type = UNLISTED
      wait = yes
      user = root
      server = /usr/local/encase/enlinuxpc
      server_args = -i -p /usr/local/encase
      }

    • 2.c: Restart the xinetd service.

I've done all these steps, however the servlet still not running.

  1. So how can I start it manually?
  2. Is there something missing for method 2?

I'm using Ubuntu.

0

If type is stream, wait should always be no.

http://linux.die.net/man/5/xinetd.conf

under "SENSOR", last sentence.

  • wait just determines how to handle subsequent connections - no mean xinetd will spawn new threads of the server for each new connection, while yes means xinetd will stop listening on that port and all future connections are expected to be handled by the server. – Dani_l Nov 22 '16 at 15:14
0

It is also possible to simply run the servlet from the command shell as a daemon using;

./enlinux64 -d

Add -p to specify a port other than the default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.