1

I am using a Ubuntu Laptop on a WiFi router. I have installed SSH server on it so that I can access it from my office network. I have forwarded port 7000 from my router settings. Now, when I try to ping the IP address of my router from my office network, I get a reply. However, I am still not able to reach my Ubuntu machine though. What I am missing here? I'd appreciate your answers.

  • Are you sure your WiFi router setup allows this? What about system firewall on the Ubuntu system? What about any firewall on the Windows system? Are both ipv4 and ipv6 allowed on all components (Ubuntu, Windows, Wifi Router)? – mdpc Jan 16 '15 at 2:46
  • I have forwarded the port 7000 in my router. Now I am not sure what to do next. – Sankalp Jan 18 '15 at 1:57
1
  • You need to make sure your iptables rules allow access to the SSH port.
  • Your router needs to forward from port 7000 to 22 (the default ssh port).
  • In /etc/hosts.allow, add the line:

    ALL: sshd
    
  • In /etc/ssh/sshd_config, have the following settings:

    Port 22
    
    UsePAM yes
    AllowUsers YOUR_USERNAME_HERE
    
  • If this does not work, we can try tracing your network and see if that's the problem.

  • If you need help configuring iptables to allow access, just ask and we will set that up as well.

Also: Can you send pings out from the Linux box? I.e., ping google.com from your Linux laptop.

| improve this answer | |
  • Thanks for the comment, I have added the hosts.allow and sshd_config file as you said. I am not sure how to make change iptable rules and how to forward from port 7000 to 22. Could you please help me with that? – Sankalp Jan 22 '15 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.