1

I'M trying to rsync between two dirs using:

rsync -atO --ignore-existing /src 1.1.1.1:/target/

The target dir is mounted via cloudfuse and the source dir is a regular one.

I get an error:

rsync: failed to set times on "/target/somefile": Function not implemented (38) rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1070) [sender=3.0.9]

1

Apparently cloudfuse doesn't support setting modification times on existing files (the "not implemented" error).

Hence you need to tell rsync not to try it:

rsync -a --no-times --ignore-existing /src 1.1.1.1:/target/

The -t you supplied was implied by -a and needs to be turned off, hence --no-times. Also -0 makes no sense as you're not using *from/filter files.

3
  • it's a capital O, not zero
    – dimid
    Jan 15 '15 at 14:11
  • also I don't see --no-times in rsync's man page (version 3.0.9)
    – dimid
    Jan 15 '15 at 14:27
  • 1
    OK, however -O becomes obsolete with --no-times; you can find info about --no-times if you look for --no-OPTION in the man page.
    – wurtel
    Jan 15 '15 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.