Where once was the filename of the file now there is a black stripe, preventing me to see what I'm editing.

enter image description here

To clarify a bit, it's that black stripe between "F1" and "All", when I did the screenshot I was editing my .emacs file.

I'm running GNU Emacs 23.2.1 (with the -nw flags) on Ubuntu 11.04.

I've tried executing emacs -q, the graphical interface pops up and the file name is correctly readable.

Here is my .emacs:

(defconst user-init-dir '~/Dropbox/emacs)
(add-to-list 'load-path "~/Dropbox/emacs")

(add-to-list 'load-path "~/Dropbox/clojure/clojure-mode")
(require 'clojure-mode)

(eval-after-load "slime" 
  '(progn (slime-setup '(slime-repl))))

(add-to-list 'load-path "~/Dropbox/emacs/slime")
(require 'slime)

;;line numbers
;;parens highlight
(show-paren-mode 1)

(require 'package)
(add-to-list 'package-archives
  '("marmalade" . "http://marmalade-repo.org/packages/"))

;;steve yegge's js mode http://code.google.com/p/js2-mode/wiki/InstallationInstructions
(setq load-path (append (list (expand-file-name "~/Dropbox/emacs/js2")) load-path))
(autoload 'js2-mode "js2" nil t)
(add-to-list 'auto-mode-alist '("\\.js$" . js2-mode))

;;save how the session was when i exited http://www.gnu.org/s/libtool/manual/emacs/Saving-Emacs-Sessions.html
(desktop-save-mode 1)

EDIT: Sadly this seems to be bigger than I thought, seems to be a wider configuration of colors which somehow I changed, I'm almost certain of this because now man does not show flags letters for the switches in its pages and completions in emacs are not shown.

Anyway, this just for the sake of completeness, maybe I'll open a new question on this after I've searched a bit more...

  • It might help to know platform context when you saw this. OS, terminal emulation (if any), version of emacs, etc. OTOH, I've never seen anything like it, so maybe context won't help. – Shannon Severance Aug 2 '11 at 22:10
  • With more information this might be better off on Super User or Stack Overflow. – ChrisF Aug 2 '11 at 22:16
  • I've added the OS and Emacs version, what else might be needed? – Alberto Zaccagni Aug 2 '11 at 22:19
  • 1
    Is Emacs executing in a terminal or in its own window? Since emacs -q is fine, the problem is in your ~/.emacs (or in one of the files it loads); post this file. You've apparently configured some face to be black on black. – Gilles 'SO- stop being evil' Aug 3 '11 at 0:06
  • 1
    @AlbertoZaccagni Start emacs -q ~/.emacs and repeatedly press Ctrl+Alt+E Ctrl+Alt+X to execute its statements in sequence until the color changes. – Gilles 'SO- stop being evil' Aug 3 '11 at 7:25

The buffer name is in the mode-line-buffer-id face, applied above the mode-line face. By default, on a dark background in a terminal, mode-line is in black on white and mode-line-buffer-id is bold; maybe you accidentally gave it a black foreground.

| improve this answer | |
  • Ok, I've never did this on purpose, but maybe I did it without knowing it :P, do you know where I could check for this? – Alberto Zaccagni Aug 3 '11 at 7:20
  • 1
    @Alberto Zaccagni: Do M-x customize-face RET mode-line-buffer-id RET – Teddy Aug 3 '11 at 9:29
  • Your command above helped me a lot, the problem can be solved in that form, thank you very much :) – Alberto Zaccagni Aug 3 '11 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.