1

I'm trying to build the devel/boost-libs on my FreeBSD 10.1.

But I alway get this error

./boost/math/special_functions/detail/lanczos_sse2.hpp:13:10: fatal error:    'emmintrin.h' file not found
#include <emmintrin.h>
         ^
1 error generated.

and

./boost/math/special_functions/detail/lanczos_sse2.hpp:13:10: fatal error: 'emmintrin.h' file not found
#include <emmintrin.h>
         ^
1 error generated.

my config

make showconfig
===> The following configuration options are available for boost-libs-1.55.0_4:
     DEBUG=off: Build with debugging support
     ICU=on: Boost.Regex with ICU unicode support
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     VERBOSE_BUILD=off: Show compiler messages

So what exactly did I miss that I can't build this port successfully?

1
  • Hope someone could help, have the same problem :/ – demonking Jan 15 '15 at 20:48
1

I found a similar bug report in the bug tracker which gave me the right hint. https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=190669#c11

Basically the Include directory was missing. So I use jails and my clang is version 3.4.1 but in my basejail include directory where only the include files for 3.3. So the solution was just to copy the include files from base to my jails.

$ cd /usr/jails/basejail/usr/include/clang
$ ls
3.3
$ sudo cp -r /usr/include/clang/3.4.1 /usr/jails/basejail/usr/include/clang
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.