2

I tried modifying my ~/.ssh/config file to allow automatic fast X forwarding as per this site http://xmodulo.com/how-to-speed-up-x11-forwarding-in-ssh.html

I then tried logging into a server and running xeyes just to see if things were working. They weren't. It seems to me like nothing is reading the config file.

These sites suggest the permissions of home should be 755 or less; .ssh should be 755 or less; config 644 or less. The permissions I am using then are 750 (home), 700 (.ssh) and 644 (config). Still nothing. Any ideas?

Edit1: As requested in the comments.

ssh -vvv -F ~/.ssh/config [email protected] generates the following output

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /home/ohnoplus/.ssh/config
debug3: ciphers ok: [blowfish-cbc,arcfour]
debug2: ssh_connect: needpriv 0
debug1: Connecting to HOST [IP] port 22.
debug1: Connection established.
debug1: identity file /home/ohnoplus/.ssh/id_rsa type -1
debug1: identity file /home/ohnoplus/.ssh/id_rsa-cert type -1
debug1: identity file /home/ohnoplus/.ssh/id_dsa type -1
debug1: identity file /home/ohnoplus/.ssh/id_dsa-cert type -1
debug1: identity file /home/ohnoplus/.ssh/id_ecdsa type -1
debug1: identity file /home/ohnoplus/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/ohnoplus/.ssh/id_ed25519 type -1
debug1: identity file /home/ohnoplus/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH_5* compat 0x0c000000
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "HOST" from file "/home/ohnoplus/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/ohnoplus/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: [email protected],[email protected],ssh-rsa
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
---kex_parse_kexinit lines removed---
debug2: mac_setup: setup hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: setup hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<3072<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: bits set: 1558/3072
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA redacted
debug3: load_hostkeys: loading entries for host "redactedhost.edu" from file "/home/ohnoplus/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/ohnoplus/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: load_hostkeys: loading entries for host "redactedip" from file "/home/ohnoplus/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /home/ohnoplus/.ssh/known_hosts:2
debug3: load_hostkeys: loaded 1 keys
debug1: Host 'redactedhost.edu' is known and matches the RSA host key.
debug1: Found key in /home/ohnoplus/.ssh/known_hosts:1
debug2: bits set: 1531/3072
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: ohnoplus@winterrain (0x7fab75e63000),
debug2: key: /home/ohnoplus/.ssh/id_rsa ((nil)),
debug2: key: /home/ohnoplus/.ssh/id_dsa ((nil)),
debug2: key: /home/ohnoplus/.ssh/id_ecdsa ((nil)),
debug2: key: /home/ohnoplus/.ssh/id_ed25519 ((nil)),
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug3: start over, passed a different list publickey,gssapi-keyex,gssapi-with-mic,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: ohnoplus@host1
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp 61:79:08:... redacted
debug3: sign_and_send_pubkey: RSA 61:79:08:... redacted
debug1: Authentication succeeded (publickey).
Authenticated to redactedhost.edu ([redactedip]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting [email protected]
debug1: Entering interactive session.
debug2: callback start
debug2: fd 3 setting TCP_NODELAY
debug3: packet_set_tos: set IP_TOS 0x10
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug2: channel 0: request shell confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel 0: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0
Last login: Wed Jan 14 10:54:32 2015 from redacted
6
  • 1
    Does it work without the config file i.e. ssh -X user@host? If not then the option X11Forwarding may be disabled on the server. Jan 13, 2015 at 18:49
  • Yes, it does work with ssh -X.
    – ohnoplus
    Jan 14, 2015 at 19:12
  • If you use ssh -v, does it say that it's reading the configuration file?
    – Barmar
    Jan 14, 2015 at 20:41
  • 1
    Try ssh -vvv -F ~/.ssh/config ... Jan 14, 2015 at 22:07
  • Done, please see edits. Still no x forwarding though.
    – ohnoplus
    Jan 14, 2015 at 22:31

0

You must log in to answer this question.

Browse other questions tagged .