1

On my LinuxMint laptop, i have a recurring problem with my bridge br0. On each start up, the default route does not work. The routing table uses eth0 instead of br0 probably because of dhcp. i roam with the laptop so turning off dhcp is not an option. I need to access VMs at home, work, and on the road. Bridges work with dhcp, but for some reason eth0 is not behaving like a manual interface.

$ip route
default via 192.168.1.1 dev eth0

The internet is available as soon as:

$sudo ip route del default
$sudo ip route add default via 192.168.1.1 dev br0

Why is it using the dev eth0 when it needs to use dev br0?

In /var/lib/NetworkManager/, there is a dhclient lease file for eth0, but /etc/NetworkManager/system-connections/Wired Connection 1 has method = manual.

  • 2
    Is your dhcp client bound to br0 or to eth0? – wurtel Jan 13 '15 at 7:53
  • Maybe, but hard to answer that question. Nice to have a script that interrogates the major dhcpc type daemons. NetworkManager "appeared" to be disabled using its gui interface but its service was running. Also had a gui for dhcpd called "Network Configurator 0.6.0" in the taskbar but it also said dhcpcd was not running. The only thing that changed was that the kernel was updated and it might be working now, but will have to test more. – rjt Jan 17 '15 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.